Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Extensions break offline #781

Open
gwynm opened this issue Nov 25, 2019 · 5 comments
Open

Extensions break offline #781

gwynm opened this issue Nov 25, 2019 · 5 comments

Comments

@gwynm
Copy link

@gwynm gwynm commented Nov 25, 2019

It seems like, if you're offline, all your extensions silently fail to work (and it's not clear why).

I verified by going online and all my extensions started working again.

This is a very disconcerting experience (especially if the extension in question is a visual theme!).

I think the fix should be:

  • "Licence validation", if necessary, should persist, spotify-style. Maybe go online every 3 or 6 months to keep extension access.

  • If extensions are disabled due to inability to validate the licence, make the reason extremely obvious.

@mobitar

This comment has been minimized.

Copy link
Member

@mobitar mobitar commented Nov 25, 2019

Platform/OS/Version?

@gwynm

This comment has been minimized.

Copy link
Author

@gwynm gwynm commented Nov 25, 2019

If this isn't shallow / intended behaviour, I'll dig a bit deeper and do a proper bug report! :) This is 3.0.16 on Linux. Will attempt to repro properly tomorrow.

@SiGamma

This comment has been minimized.

Copy link

@SiGamma SiGamma commented Nov 26, 2019

I‘m pretty sure it isn’t (there’s even a checkbox for offline use of some sort IIRC), mine work just fine offline, on macOS and Windows, though.

@gwynm

This comment has been minimized.

Copy link
Author

@gwynm gwynm commented Nov 26, 2019

Gotcha, this sounds like a me problem :).

@mobitar

This comment has been minimized.

Copy link
Member

@mobitar mobitar commented Nov 26, 2019

For the record, our most recent update migrated offline extensions to using a local server on a local port (instead of using file:// paths). So it might be a firewall issue..

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.