Permalink
Browse files

valgrind: always remove mmacosx-min-version

Needed on 10.6 and 10.8, so I can only assume it is needed on 10.7 as
well.

Signed-off-by: Jack Nagel <jacknagel@gmail.com>
  • Loading branch information...
1 parent c59910e commit e7558313d462893d106ac7f40acc3e6686658b9b @jacknagel jacknagel committed Aug 23, 2012
Showing with 2 additions and 4 deletions.
  1. +2 −4 Library/Formula/valgrind.rb
@@ -23,10 +23,8 @@ class Valgrind < Formula
skip_clean 'lib'
def install
- # avoid __bzero when building against OS X 10.8 sdk
- if MacOS.version >= 10.8
- ENV.remove_from_cflags "-mmacosx-version-min=#{MacOS.version}"
- end
+ # avoid undefined symbol __bzero
+ ENV.remove_from_cflags "-mmacosx-version-min=#{MacOS.version}"
args = ["--prefix=#{prefix}", "--mandir=#{man}"]
if MacOS.prefer_64_bit?

0 comments on commit e755831

Please sign in to comment.