Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

RDP Wrap not working on windows 10 build 10.0.17763.437 (1809) & 10.0.17134.706 (1803) #763

Open
roymanoj opened this issue Apr 27, 2019 · 20 comments

Comments

Projects
None yet
@roymanoj
Copy link

commented Apr 27, 2019

Hello, I upgraded to the new version of Windows and RDP Wrapper doesn't appear to work on this latest build.
It was working so far but suddenly stopped working after recent update from microsoft.

Everything showing correct and working but when I am trying to login it's showing Error : "The no of connection of this computer is limited and all connections are in use"

Just thought I'd let you guys know!
Thanks for all your help.

@roymanoj roymanoj changed the title RDP Wrap not working on windows 10 build 10 RDP Wrap not working on windows 10 build 10.0.17763.437 (1809) & 10.0.17134.706 (1803) Apr 27, 2019

@dzhaodude

This comment has been minimized.

Copy link

commented Apr 27, 2019

I hope for fix either.
Thanks

Build 10.0.17134.706
[-] This version of Terminal Services is not supported.
Try running "update.bat" or "RDPWInst -w" to download latest INI file.
If it doesn't help, send your termsrv.dll to project developer for support.

@DCS59

This comment has been minimized.

Copy link

commented Apr 27, 2019

This issue has been addressed in several posts already. The official version has not been updated but there are patches and procedures that will update the .ini file to work with both these versions. Read the prior posts to find solution. RDPWrap is a volunteer project and the primary author has not updated the official version. The community has developed patches that have to be manually installed.

@andrew521

This comment has been minimized.

Copy link

commented Apr 28, 2019

This issue has been addressed in several posts already.

Although the issue is being discuses in six different tickets, it is far from being "addressed" at this time. While we all understand that RDPWrap is a volunteer project, there is no valid solution at this time and everyone would appreciate the effort of getting this fixed.

@ZeljkoManjkas

This comment has been minimized.

Copy link

commented Apr 29, 2019

Can you try with this ini file
rdpwrap.zip

(Unpack ini, overwrite rdpwrite.ini file in Program Files\RDP Wrapper, run rdpwinst.exe -r as admin)

Work for me on 10.0.17763.437 (x86) and 10.0.17134.706 (x86 and x64).

@roymanoj

This comment has been minimized.

Copy link
Author

commented Apr 29, 2019

Can you try with this ini file
rdpwrap.zip

(Unpack ini, overwrite rdpwrite.ini file in Program Files\RDP Wrapper, run rdpwinst.exe -r as admin)

Work for me on 10.0.17763.437 (x86) and 10.0.17134.706 (x86 and x64).

Thanks a lot, Your solution solved my problem only catch that I have used another rdpwrap.ini here I am attaching my working INI file, hope this will be helpful for others.

rdpwrap_working_version.zip

@ZeljkoManjkas

This comment has been minimized.

Copy link

commented Apr 29, 2019

Thanks a lot, Your solution solved my problem only catch that I have used another rdpwrap.ini here I am attaching my working INI file, hope this will be helpful for others.

rdpwrap_working_version.zip

Your ini have duplicated section for [10.0.17763.437] .
SLInit section [10.0.17763.437-SLInit] is not separated from base definition.
Section [10.0.17134.706] is after [10.0.17763.437] .

Thank you for some sections that I don't have.

@andrew521

This comment has been minimized.

Copy link

commented Apr 30, 2019

I have tried rdpwrap_working_version.zip and it is definitely an improvement. It allows me to open a second RDP session which is great but the session is always a new one instead of opening the previously disconnected session.

@CrimsonKidA

This comment has been minimized.

Copy link

commented May 2, 2019

@roymanoj 's file worked for me. Be sure to not leave any ".bak" or other junk behind in C:\Program Files\RDP Wrapper (seemed to prevent TermService from starting). I also ran net stop TermService -> copied the good .INI file in, -> then ran net start TermService (but that may not be obligatory).

@Kyrluckechuck

This comment has been minimized.

Copy link

commented May 2, 2019

Alright, long story short, was trying to make it so there could only be a single user session ever, so disconnecting would resume the same session in addition to connecting would kick someone off if they were signed in (this account is only used by me, so this is ideal to resume my work).

I tried both above files, the first caused issues with termservice not wanting to start, but the second started perfect. However, it had the same issue as the other examples I'd found so far.
I manually removed two duplicate sections for 10.0.17763.437 and 10.0.17763.437-SLInit in the above one and also modified the multi-session settings at the top of the ini, with it now working exactly as I'd like.

I know this is a bit of an edge case for many users, but if that's something you need, please find it attached!

rdpwrap_corrected_single_10.0.17763.437.zip

@andrew521

This comment has been minimized.

Copy link

commented May 2, 2019

rdpwrap_corrected_single_10.0.17763.437.zip doesn't work for me. Allows multiple sessions but, as before, the session is always a new one instead of opening the previously disconnected session.

@Kyrluckechuck

This comment has been minimized.

Copy link

commented May 3, 2019

@andrew521 just confirming, your Windows version is 10.0.17763.437?

@andrew521

This comment has been minimized.

Copy link

commented May 3, 2019

Just to confirm that it is working now. The new ini file clears "single session per user" option so it just needs to be set.

@nooblyh

This comment has been minimized.

Copy link

commented May 5, 2019

After overwriting rdpwrite.ini file from ZeljkoManjkas it's still "Not listening", but "Not Supported" is fixed.
(on windows 10 build 10.0.17134.706 (1803))

@henrychca

This comment has been minimized.

Copy link

commented May 17, 2019

¿Puedes probar con este archivo ini
rdpwrap.zip?
(Descomprima ini, sobrescriba el archivo rdpwrite.ini en Archivos de programa \ RDP Wrapper, ejecute rdpwinst.exe -r como administrador)
Trabaja para mí en 10.0.17763.437 (x86) y 10.0.17134.706 (x86 y x64).

Muchas gracias. Su solución resolvió mi problema, pero solo he usado otro rdpwrap.ini. Aquí adjunto mi archivo INI de trabajo, espero que esto sea útil para otros.

rdpwrap_working_version.zip

Confirmo funcionamiento hoy 16/05/2019 con este ini, en la versión 1809 17763.503

@heinihaoa

This comment has been minimized.

Copy link

commented May 23, 2019

Can you try with this ini file
rdpwrap.zip

(Unpack ini, overwrite rdpwrite.ini file in Program Files\RDP Wrapper, run rdpwinst.exe -r as admin)

Work for me on 10.0.17763.437 (x86) and 10.0.17134.706 (x86 and x64).

friend how can I do? thanks a lot!

{

D:\Program Files\RDPWrap>rdpwinst.exe -r as admin
RDP Wrapper Library v1.6.2
Installer v2.5
Copyright (C) Stas'M Corp. 2017

[*] Restarting...
[+] TermService found (pid 3816).
[*] No shared services found.
[*] Terminating service...
[*] Starting TermService...
[-] StartService error (code 1056).
[+] Done.

}

@perlestius

This comment has been minimized.

Copy link

commented May 25, 2019

Alright, long story short, was trying to make it so there could only be a single user session ever, so disconnecting would resume the same session in addition to connecting would kick someone off if they were signed in (this account is only used by me, so this is ideal to resume my work).

I tried both above files, the first caused issues with termservice not wanting to start, but the second started perfect. However, it had the same issue as the other examples I'd found so far.
I manually removed two duplicate sections for 10.0.17763.437 and 10.0.17763.437-SLInit in the above one and also modified the multi-session settings at the top of the ini, with it now working exactly as I'd like.

I know this is a bit of an edge case for many users, but if that's something you need, please find it attached!

rdpwrap_corrected_single_10.0.17763.437.zip

I had the same problem on Win10 x64 with 10.0.17763.437 version of termsrv.dll. Your ini-file works fine for me. Thanks a lot!

@contras2k

This comment has been minimized.

Copy link

commented May 28, 2019

Can you try with this ini file
rdpwrap.zip

(Unpack ini, overwrite rdpwrite.ini file in Program Files\RDP Wrapper, run rdpwinst.exe -r as admin)

Work for me on 10.0.17763.437 (x86) and 10.0.17134.706 (x86 and x64).

This one is a good base for 10.0.17763.437 (x86), but it has one subtle and one more serious error.
Section [10.0.17763.437] has two duplicate entries:
LocalOnlyOffset.x64=77A41
and no entry LocalOnlyOffset.x86 . I managed to find the position, it should be:
LocalOnlyOffset.x86=AFE24

Section [10.0.17763.437-SLInit] lacks last entry, that should be:
bFUSEnabled.x64 =ECAD0

@davext

This comment has been minimized.

Copy link

commented May 31, 2019

Can you try with this ini file
rdpwrap.zip

(Unpack ini, overwrite rdpwrite.ini file in Program Files\RDP Wrapper, run rdpwinst.exe -r as admin)

Work for me on 10.0.17763.437 (x86) and 10.0.17134.706 (x86 and x64).

Worked for me too!
Here's my system information :)

OS Name             : Microsoft Windows 10 Home
OS Version          : 10.0.17134 N/A Build 17134
OS Manufacturer     : Microsoft Corporation
OS Configuration    : Standalone Workstation
OS Build Type       : Multiprocessor Free
System Boot Time    : 5/29/2019, 10:29:40 PM
System Manufacturer : Dell Inc.
System Model        : XPS 8700
System Type         : x64-based PC
System Directory    : C:\WINDOWS\system32
System Locale       : en-us;English (United States)
Hotfix(s)           : 14 Hotfix(s) Installed.,[01]: KB4100347,[02]: KB4343669,[03]: KB4456655,[04]: KB4465663,[05]:
                      KB4471331,[06]: KB4477137,[07]: KB4480979,[08]: KB4485449,[09]: KB4487038,[10]: KB4489907,[11]:
                      KB4493478,[12]: KB4497398,[13]: KB4497932,[14]: KB4499167

@camoiaguiar

This comment has been minimized.

Copy link

commented Jun 21, 2019

Can you try with this ini file
rdpwrap.zip
(Unpack ini, overwrite rdpwrite.ini file in Program Files\RDP Wrapper, run rdpwinst.exe -r as admin)
Work for me on 10.0.17763.437 (x86) and 10.0.17134.706 (x86 and x64).

Thanks a lot, Your solution solved my problem only catch that I have used another rdpwrap.ini here I am attaching my working INI file, hope this will be helpful for others.

rdpwrap_working_version.zip

Funcionou perfeitamente

@secret00

This comment has been minimized.

Copy link

commented Jun 27, 2019

any support for 17763.253

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.