Permalink
Browse files

Specify Plack >= 0.995 version for testing & recommending

  • Loading branch information...
1 parent df99a8b commit 4fa49bd2a2b2df52f6b1024b00687a3427c003e6 @stash committed Oct 1, 2010
Showing with 4 additions and 3 deletions.
  1. +1 −1 Makefile.PL
  2. +3 −2 t/60-plack.t
View
2 Makefile.PL
@@ -63,7 +63,7 @@ WriteMakefile(ev_args(
},
META_MERGE => {
recommends => {
- 'Plack' => 0.9938,
+ 'Plack' => 0.9950,
'Test::TCP' => 0.16,
},
resources => {
View
5 t/60-plack.t
@@ -7,10 +7,11 @@ BEGIN {
$ENV{PLACK_SERVER} = 'Feersum';
$ENV{PLACK_DEV} = 'development';
- plan skip_all => "Need Plack::Test to run this test"
- unless eval "require Plack::Test; 1";
+ plan skip_all => "Need Plack >= 0.9950 to run this test"
+ unless eval 'require Plack; $Plack::VERSION >= 0.995';
}
+use Plack::Test;
use Plack::Test::Server;
use Plack::Loader;

0 comments on commit 4fa49bd

Please sign in to comment.