Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Commits on Apr 15, 2011
  1. Changes for 1.200

    authored
  2. Make SIGPIPE POD more correct

    authored
  3. Ignore SIGPIPE

    authored
    TODO: restore the default handler for the scope of any callbacks.
  4. Align the line-number in traces

    authored
Commits on Apr 13, 2011
  1. Changes for 1.101

    authored
  2. Try to fix 62-plack-runner again

    authored
    * Fix incorrect "skip" count
    * Include bin and scriptdir in directory search
    * use "exp" flavours of the searched directories
Commits on Apr 11, 2011
  1. Changes for 1.001

    authored
  2. Fix a long-standing truncated write defect.

    authored
    When more than one write buffer (iomatrix) was getting used to compose a response, only the first buffer was getting sent.
    
    Instead, try to call writev() again immediately if another iomatrix is pending (until writev() returns EAGAIN or some other error).
    
    This defect has likely been present for a long time, since at least 0cc3309 (2010 Jun 22) when Feersum changed from write() to writev().
Commits on Apr 9, 2011
  1. Changes for 1.002

    authored
  2. Add missing MANIFEST entry

    authored
  3. Try fix persistent fail of 62-plack-runner.t

    authored
    This seems to fail frequently via CPAN Testers.  Replaced looking for plack in the PATH with a search through the site/vend bin/script dirs.  If an executable script isn't found, skip the tests.
  4. Bump Test::TCP dep

    authored
Commits on Apr 8, 2011
  1. Update picohttpparser

    authored
Commits on Jan 31, 2011
  1. Bump for 1.001

    authored
Commits on Nov 22, 2010
  1. Changes for 1.000

    authored
  2. Update POD for 1.000

    authored
  3. Specify psgi.run_once as per PSGI 1.1 spec.

    authored
    * also fix t/60-plack.t since changing the version number
  4. Feersum supports the (unreleased) PSGI 1.1 spec

    authored
    stash ‣ miyagawa_: qq: should psgi.version say [1,0] or [1,1]? i noticed Starman (Starlet?) had that. should Feersum?
    miyagawa_ ‣ stash: if you use psgix.io then 1.1
    
    Spec: https://github.com/miyagawa/psgi-specs/blob/master/PSGI.pod
Commits on Nov 14, 2010
  1. @audreyt

    * Older ExtUtils::MakeMaker doesn't grok CONFIGURE_REQUIRES, so be ex…

    audreyt authored
    …plicit
    
      in using ExtUtils::Makefile 6.51 in Makefile.PL.
Commits on Oct 28, 2010
Commits on Oct 27, 2010
  1. Changes for 0.986

    authored
Something went wrong with that request. Please try again.