New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Taxonomies field with dash listing causes errors when saving in the control panel #1308

Closed
castirondesign opened this Issue Mar 8, 2017 · 0 comments

Comments

Projects
None yet
2 participants
@castirondesign

castirondesign commented Mar 8, 2017

Expected behaviour

The two below formats should work the same:

taxonomies:
  - tags
taxonomies:
  tags: true

Actual behaviour

When using - tags the fields shows up properly in the cp, but it doesn't detect current terms and it errors out when attempting to save either blank or new terms.

Server configuration

Operating system:
Mac OS local, Ubuntu remote

Web server:
Apache local, nginx remote

PHP version:
7.1 local, 5.5.9 remote

Statamic version:
2.5.5

Updated from an older Statamic or fresh install:
Updated. One started on 2.5.1, another started pre 2.5

List of installed addons:
None

Logs

If any logs (browser, server, or Statamic) are appropriate...

There was a problem saving the data. Please check your logs.
ErrorException: Undefined offset: 0 in /statamic/core/CP/Publish/Publisher.php:205

@jasonvarga jasonvarga self-assigned this Mar 16, 2017

@jasonvarga jasonvarga closed this Mar 17, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment