New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Two locales: Missing translation for cp.passwords on login page #1461

Closed
macbruker opened this Issue Jun 11, 2017 · 2 comments

Comments

Projects
None yet
4 participants
@macbruker

macbruker commented Jun 11, 2017

Screenshot of login page

Expected behaviour

Label should read Password or the appropriate translation

Actual behaviour

Label reads 'cp.passwords'

Steps to reproduce

  1. Add an additional locale
  2. Set English as the second locale
  3. Load Login Page

Server Details

Operating System: Mac OS X

Web Server: MAMP Pro

PHP Version: 7.0.12

Statamic Version: 2.5.10

Updated from an older Statamic or fresh install: Tested on upgraded and fresh install

List of installed addons: No addons

I have tried to test this thoroughly, so I hope this is correctly reported.

@ebeauchamps

This comment has been minimized.

ebeauchamps commented Jun 13, 2017

if you add locale: en in cp.yaml the login will always be displayed in English

Then you can add locale: xx in each user own file, defining xx as the locale that specific user must see in the CP

@PeterEmil

This comment has been minimized.

PeterEmil commented Jan 16, 2018

I got this behavior as well. It disappears when you duplicate cp.php in the site/lang folder and put that in its own language-folder.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment