New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

CP CSS Override not loading when 'site' folder is above the webroot. #1639

Closed
deanwhillier opened this Issue Oct 31, 2017 · 0 comments

Comments

Projects
None yet
2 participants
@deanwhillier

deanwhillier commented Oct 31, 2017

Actual behaviour

The CP CSS override.css file doesn't load when the site folder has been moved above the webroot (i.e. webroot/../site/). In this scenario, adding a blank override.css file to webroot/site/helpers/cp/ allows the actual `webroot/../site/helpers/cp/override.css' file to be loaded.

Note: just having the override.css file in the webroot/site/helpers/cp folder doesn't work either.

Steps to reproduce

  1. Setup a fresh copy of Statamic with site, local and statamic folders etc. configured above the webroot.
  2. Add some styles to the override.css default file now located in webroot/../site/helpers/cp folder.
  3. Reload the CP = styles aren't loaded
  4. Add a blank override.css file to a webroot/site/helpers/cp folder
  5. Reload the CP = styles are now loaded

Server Details

Operating System: macOS 10.12.6 (MAMP)

Web Server: Apache

PHP Version: 7.1.6

Statamic Version: 2.7.1

Updated from an older Statamic or fresh install: Fresh install

Aside

This feature is very helpful, thanks so much!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment