New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Search Index needs to be manually updated after changing search settings, even when auto index is turned on #1656

Closed
beckysoll opened this Issue Nov 10, 2017 · 1 comment

Comments

Projects
None yet
3 participants
@beckysoll

beckysoll commented Nov 10, 2017

Expected behaviour

If auto index is turned on, I'd expect the search index to be updated when changing/updating the search settings from within the CP.

Actual behaviour

Index is not updated, search results get wonky. Even had my global set somehow showup. Running php please search:update fixes things consistently.

Steps to reproduce

  1. Go to /cp/settings/search
  2. Add or remove some searchable fields
  3. Try to search the frontend of the site

Server Details

Search page hasn't been made live yet so i've only tested this locally: Mac / MAMP Pro

PHP Version: 7.1.8

Statamic Version: 2.7.2

Updated from an older Statamic or fresh install: Updated, started at 2.6.8

List of installed addons:
none

@jackmcdade

This comment has been minimized.

Member

jackmcdade commented Feb 19, 2018

Fixed for next release.

@jackmcdade jackmcdade closed this Feb 19, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment