New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

cp uses incorrect urls when using 'valet share' #1882

Closed
lardnicus opened this Issue Apr 10, 2018 · 1 comment

Comments

Projects
None yet
2 participants
@lardnicus

lardnicus commented Apr 10, 2018

Expected behaviour

using 'valet' automatically generates urls like http://myfoldername.localhost/
running 'valet share' on a site generates a url like http://1234example.ngrok.io
this url can be placed in site > settings > system.yaml

locales:
en:
full: en_US
name: English
url: http://1234example.ngrok.io

site is expected to use the url specified in the settings.

Actual behaviour

site works to a certain extent, however some urls in the Statamic control panel are replaced with the default valet url (eg http://myfoldername.localhost/)

this url is not in any of the project files (fresh install and I also performed a full folder search).

Steps to reproduce

  1. download a fresh copy of statamic v2
  2. use laravel valet
  3. start 'valet share' and then try to navigate to a blog post in the Statamic control panel

Server Details

Operating System:
MacOS 10.13.3

Web Server:
laravel valet

PHP Version:
php71

Statamic Version:
latest

Updated from an older Statamic or fresh install:
fresh install

List of installed addons:
non

Logs

not applicable

@jasonvarga

This comment has been minimized.

Member

jasonvarga commented May 15, 2018

This will be fixed in 2.9 - what you'd need to do is place the ngrok url in your system.yaml locales array (like you demonstrated)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment