New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

2.9.X Asset field gets stuck loading when included via a partial fieldset. #1936

Closed
benfurfie opened this Issue May 22, 2018 · 8 comments

Comments

Projects
None yet
5 participants
@benfurfie

benfurfie commented May 22, 2018

Describe the bug
The asset field gets stuck loading when included via a partial fieldset.

To Reproduce
Steps to reproduce the behavior:

  1. Create a fieldset.
  2. Create an assets field.
  3. Save it.
  4. Create a new fieldset.
  5. Include that first fieldset into the new one as a partial field.
  6. Create a new page with that fieldset.
  7. You should see the field name appear, with the ajax gif below it.

Expected behavior
It should return an upload box.

Screenshots
assets_bug

Environment details (please complete the following information):

  • Statamic Version [e.g. 2.9.1]
  • Fresh Install and Upgrade:
  • OS: MacOS 10.13.4
  • Browser: Chrome, Firefox, Safari
  • Web Server: Valet
  • PHP Version: 7.1
  • Addons installed: None
@jackmcdade

This comment has been minimized.

Member

jackmcdade commented May 22, 2018

Working on this now. Likely the same issue as #1935 too, so we'll hopefully get two birds with one stone. Hang in there!

@bgarrant

This comment has been minimized.

bgarrant commented May 22, 2018

Great. Keep me posted.

@efoken

This comment has been minimized.

efoken commented May 24, 2018

@jackmcdade Any solution in sight? 😈

@bgarrant

This comment has been minimized.

bgarrant commented May 28, 2018

We need this fix badly. 5 client sites experiencing it when using asset field in Bard

@benfurfie

This comment has been minimized.

benfurfie commented May 28, 2018

Can you not downgrade until it's fixed @bgarrant?

@bgarrant

This comment has been minimized.

bgarrant commented May 28, 2018

I just went back to 2.8.12 for now yes.

@jasonvarga

This comment has been minimized.

Member

jasonvarga commented May 28, 2018

We are working on it.
I believe you can workaround it by not using a partial. Just copy/paste your fields into the appropriate places.

@bgarrant

This comment has been minimized.

bgarrant commented May 28, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment