New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Taxonomy field is empty when editing entry. #2011

Closed
philipboomy opened this Issue Jun 8, 2018 · 2 comments

Comments

Projects
None yet
3 participants
@philipboomy

philipboomy commented Jun 8, 2018

Describe the bug
The taxonomy tag disappear after save of entry. If you edit the entry and check the sidebar/meta tab the taxonomy is gone. It is showing in the entry.md file though.

tags:

  • tagname

To Reproduce
Steps to reproduce the behavior:

  1. Create entry, enter a taxonomy and click save
  2. Edit the same entry and go to sidebar/meta tab and see that taxonomy field is empty.

Expected behavior
That the field would contain the tag

Screenshots
https://cl.ly/2v3C1i3U1f0U

Environment details (please complete the following information):

  • Statamic Version: 2.9.7
  • Upgrade from 2.9.6
  • macOS 10.12.6
  • Browser: Firefox
  • Web Server: Valet
  • PHP Version: 7.2
  • Addons installed: None

Additional context
I mentioned it here #2000 thinking it was related to same problem since it was working when the prepend was happening.

@jackmcdade jackmcdade added the bug label Jun 8, 2018

@jackmcdade

This comment has been minimized.

Member

jackmcdade commented Jun 8, 2018

Confirmed. Working on a fix.

@jasonvarga

This comment has been minimized.

Member

jasonvarga commented Jun 8, 2018

You can fix this temporarily by changing line 19 of statamic/core/Data/Processor.php to

$this->fieldtypes = collect($fieldset->withTaxonomies()->fieldtypes())->keyBy(function ($fieldtype) {
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment