New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Asset pages in CP don't cache images #2082

Closed
wesort opened this Issue Jul 26, 2018 · 3 comments

Comments

Projects
None yet
3 participants
@wesort

wesort commented Jul 26, 2018

Is your feature request related to a problem? Please describe.
When navigating around the assets pages of the CP the images reload on each visit. This is slows down user activity. This is especially true when doing a bulk assets activity like adding alt-text.

Describe the solution you'd like
Images to be cached by the browser.

@jackmcdade

This comment has been minimized.

Member

jackmcdade commented Jul 27, 2018

Do you have devtools open? If so, it clears the browser cache each request. The thumbnails should cache fine with it closed.

@wesort

This comment has been minimized.

wesort commented Jul 27, 2018

The issue is the same with Dev Tools open or closed.

Even without Dev Tools open navigating in and out of folders takes a few extra seconds as the images visually populate the list. For example, a folder (with 15# images, each ~200-700KB, on a 50Mbps internet connection) is taking 4-5 seconds to load. (NB: The front-end web page containing those same images loads in an instant due to the browser cache.) This is after previously visiting the page in CP only seconds before and having already run php please assets:generate-presets. Also, I've noticed that my Gravatar image is being cached.

@jasonvarga

This comment has been minimized.

Member

jasonvarga commented Jul 31, 2018

This is because of #1386 where we were a little aggressive, also caching thumbnails.
Fixed for next release!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment