New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Root of assets folder in CP still has ".." folder #2098

Closed
wesort opened this Issue Aug 3, 2018 · 6 comments

Comments

Projects
None yet
4 participants
@wesort

wesort commented Aug 3, 2018

Describe the bug
When at root of Assets there is a .. folder icon (go up one directory level). Clicking this shows all of the assets in the container and the folders are still present too. This is unexpected and confusing.

FWIW, I think that .. convention is lost on many CP users from the client side. The feedback I've had is most don't know what this does and find it confusing as they're not command line users.

To Reproduce
Steps to reproduce the behavior:

  1. Go to /cp/assets/browse/main
  2. Click on .. folder
  3. This changes url to /cp/assets/browse/main/null
  4. All assets are now displayed regardless of what folders they're in.

Expected behavior
For either:
a. That .. folder not to exist when at root.
b. That .. folder to be renamed "All assets" and for the folders to disappear once on "All assets" view
c. For that .. folder to be removed completely and replaced with breadcrumbs

Environment details (please complete the following information):

  • Statamic Version [e.g. 2.10.3]
  • Fresh Install or Upgrade: Upgrade from v.2.10.2
  • OS: Linux
  • Browser: Chrome
  • Web Server: Nginx over Apache (Webfaction)
  • PHP Version: 7.2
  • Addons installed: Logbook
@jasonvarga

This comment has been minimized.

Member

jasonvarga commented Aug 3, 2018

Weird, we don't see the .. in the root folder.

image

Anything special about your site? Are you running in a subdirectory?

@simonhamp

This comment has been minimized.

simonhamp commented Aug 3, 2018

I see this too, in Grid view. List view is fine

@simonhamp

This comment has been minimized.

simonhamp commented Aug 3, 2018

It's worth noting that this allows a user to circumvent the "Restrict to folder" option on the Asset fieldtype as they can then see images from folders other than the one that the field is restricted to.

@wesort

This comment has been minimized.

wesort commented Aug 3, 2018

I believe I'm running a pretty standard setup and I'm seeing this across multiple sites.

List view does show the .. folder if you switch from thumbnail or force the URL at /cp/assets/browse/main/null

@jasonvarga I've just granted you access to a repo for my own site. Please don't push to master (obvs!)

@simonhamp

This comment has been minimized.

simonhamp commented Aug 3, 2018

Can confirm: switching to grid view, clicking the .. folder and then switching back to list view and the .. folder shows there too.

@jackmcdade

This comment has been minimized.

Member

jackmcdade commented Aug 3, 2018

Ah ha! It's the grid mode that does it. Good catch!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment