New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

2.0.4 breaks addon resources redirection #670

Closed
lesaff opened this Issue May 6, 2016 · 2 comments

Comments

Projects
None yet
3 participants
@lesaff

lesaff commented May 6, 2016

Steps to reproduce

  1. Update to 2.0.4
  2. Open CP with your addon installed

Expected behaviour

Addon that uses $this->css->url() or $this->js->url() should be able to see those css/js working on the cp

Actual behaviour

You get Resource not found when you try to visit the css/js link directly.

Browser log

Failed to load resource: the server responded with a status of 404 (Not Found)
http://v2.dev/resources/addons/Sections/js/scripts.js 
@nlsw

This comment has been minimized.

Show comment
Hide comment
@nlsw

nlsw May 10, 2016

Jason said: "We know about the 404s in Valet. We're working on a fix. For now, you can hack in a fix by opening statamic/core/Http/ResourceServer/Server.php to line 138 and change the 4 + to 3 +."

It worked for me.

nlsw commented May 10, 2016

Jason said: "We know about the 404s in Valet. We're working on a fix. For now, you can hack in a fix by opening statamic/core/Http/ResourceServer/Server.php to line 138 and change the 4 + to 3 +."

It worked for me.

@lesaff

This comment has been minimized.

Show comment
Hide comment
@lesaff

lesaff May 10, 2016

I don't use Valet, but it is a related issue.
Changing line 150 from 5 to 4 fixed it.
Thx

lesaff commented May 10, 2016

I don't use Valet, but it is a related issue.
Changing line 150 from 5 to 4 fixed it.
Thx

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment