Browse files

BUG: setup.py py32 compatibility drop err (not used) from exceptions

  • Loading branch information...
1 parent 50f5ca2 commit 9c2c0d493db284fbd67984ebe87a033d9b02ba4b @josef-pkt josef-pkt committed Mar 23, 2012
Showing with 5 additions and 5 deletions.
  1. +5 −5 setup.py
View
10 setup.py
@@ -35,32 +35,32 @@ def check_dependency_versions(min_versions):
from distutils.version import StrictVersion
try:
from numpy.version import short_version as npversion
- except ImportError, err:
+ except ImportError:
raise ImportError("statsmodels requires numpy")
try:
from scipy.version import short_version as spversion
- except ImportError, err:
+ except ImportError:
raise ImportError("statsmodels requires scipy")
try:
from pandas.version import version as pversion
except:
raise ImportError("statsmodels requires pandas")
try:
assert StrictVersion(npversion) >= min_versions['numpy']
- except AssertionError, err:
+ except AssertionError:
raise ImportError("Numpy version is %s. Requires >= %s" %
(npversion, min_versions['numpy']))
try:
assert StrictVersion(spversion) >= min_versions['scipy']
- except AssertionError, err:
+ except AssertionError:
raise ImportError("Scipy version is %s. Requires >= %s" %
(spversion, min_versions['scipy']))
try:
#NOTE: not sure how robust this regex is but it at least allows
# double digit version numbering
pversion = re.match("\d*\.\d*\.\d*", pversion).group()
assert StrictVersion(pversion) >= min_versions['pandas']
- except AssertionError, err:
+ except AssertionError:
raise ImportError("Pandas version is %s. Requires >= %s" %
(pversion, min_versions['pandas']))

0 comments on commit 9c2c0d4

Please sign in to comment.