Add minimum matplotlib to docs #1386

jseabold opened this Issue Feb 13, 2014 · 3 comments


None yet

2 participants


We don't have one listed AFAICT. I saw somewhere we were testing for matplotlib < '1'. We shouldn't support matplotlib version < 1.0 I don't think.

@jseabold jseabold added this to the 0.6 milestone Feb 13, 2014
@jseabold jseabold added the comp-docs label Feb 13, 2014

I don't know which matplotlib version we require.
Since it's optional we never did a systematic check which version was used and is required by the different plot functions.

We might have put the version < 1.0 at some point during the transition of matplotlib to after 1., old code?.


I think we definitely should be later than 1.0. I recall problems with 0.98 a long time ago. This was in the test suite to essentially skip the tests if we have less than 1.0, so that kind of defeats the purpose of min versions.


Yes the requirement to run the code is definitely something after 1.0, maybe even higher for some functions, but I don't know what the minimum version is that would run all the plot functions.

#291 2 years ago to skip the tests, matplotlib is still optional and some functions won't work if it's too old.

If we know what versions we need, then we can raise with informative error messages, instead of just failing in the code.

The only version check that I see in regular code is mpl.__version__ >= '1.1' for the presence of tight_layout.

@jseabold jseabold closed this in dfab308 Sep 21, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment