Unable to install statsmodels in the same requirements file as numpy, pandas, etc. #1628

Closed
ervandew opened this Issue Apr 23, 2014 · 2 comments

Projects

None yet

2 participants

@ervandew

Due to the way pip works, if you have a requirements.txt file which includes statsmodels and its dependencies (numpy, pandas, etc), then attempt to run a:

$ pip install -r requirements.txt

It will fail because pip runs the setup.py of every package before installing any of the packages.

Couple related issues:
pypa/pip#25
scipy/scipy#453
pandas-dev/pandas#2732

@josef-pkt
Member

Are you using current master?

I think this has been fixed with #1267

@ervandew

#1267 looks like it should solve the issue. My appologies for the added noise.

@ervandew ervandew closed this Apr 23, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment