Unable to build #1762

Closed
detzom opened this Issue Jun 16, 2014 · 2 comments

Projects

None yet

2 participants

@detzom
detzom commented Jun 16, 2014

statsmodels is needed by another github project that I use "etsy/skyline", and I'm still unable to build your project.

I have the same error either using PIP, EASY_INSTALL, python setup.py build, from 0.5 release and actual git release.

There is the output :

python2.6 setup.py build
Traceback (most recent call last):
File "setup.py", line 388, in
check_dependency_versions(min_versions)
File "setup.py", line 117, in check_dependency_versions
from pandas.version import short_version as pversion
File "/usr/lib64/python2.6/site-packages/pandas/init.py", line 45, in
from pandas.io.api import *
File "/usr/lib64/python2.6/site-packages/pandas/io/api.py", line 7, in
from pandas.io.excel import ExcelFile, ExcelWriter, read_excel
File "/usr/lib64/python2.6/site-packages/pandas/io/excel.py", line 626, in
.format(openpyxl_compat.start_ver, openpyxl_compat.stop_ver))
ValueError: zero length field name in format

@detzom
detzom commented Jun 16, 2014

Okay...

According to : pandas-dev/pandas#7284

The problem comes from pandas 0.14.

I uninstalled it, cleaning /tmp and installed version 0.13.1 of pandas, and now install of statsmodels works.

@josef-pkt
Member

Thanks for clearing it up, closing

@josef-pkt josef-pkt closed this Jun 16, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment