pip install now fails silently #2003

Closed
jseabold opened this Issue Sep 25, 2014 · 4 comments

Projects

None yet

1 participant

@jseabold
Member

After merging #2000. Pip will now fail silently in a clean virtualenv. The problem is that doing pip install ... produces this in sys.argv which fails our don't do any dependency checking check [1].

['-c', 'egg_info', '--egg-base', 'pip-egg-info']

I'm not quite sure the fix yet actually, and I don't have time to read the entire source of pip to find out what the above means.

Unless @rgommers has a ready solution for this, I'm inclined to revert that merge, so we're back to at least giving a good error message for 0.6.

@jseabold jseabold added this to the 0.6 milestone Sep 25, 2014
@jseabold jseabold added the build label Sep 25, 2014
@jseabold
Member

This can't be entirely accurate though because it fails trying to build numpy AFAICT from my build log. TBD...

@jseabold
Member

(Part of) the problem is that statsmodels.egg-info is in our source distributions since c9a249e changed the custom sdist.

@jseabold jseabold added a commit to jseabold/statsmodels that referenced this issue Sep 25, 2014
@jseabold jseabold BLD: Use sdist from distutils. Closes #2003. 15d4c99
@jseabold
Member

No that doesn't matter as I thought it did.

@jseabold
Member

I think this is a duplicate of #1897.

@jseabold jseabold closed this Sep 25, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment