Skip to content
Permalink
Browse files

Update list of Node versions

  • Loading branch information...
kgryte committed Apr 24, 2019
1 parent cc8dce3 commit 12035dec62f889c4625872e2f30c8760870256a2
Showing with 18 additions and 2 deletions.
  1. +1 −0 .travis.yml
  2. +15 −0 appveyor.yml
  3. +1 −1 tools/make/common.mk
  4. +1 −1 tools/scripts/node_versions_run_script
@@ -33,6 +33,7 @@ sudo: true
node_js:
# Node.js
- 'node'
- '12'
- '11'
- '10'
- '9'
@@ -50,6 +50,9 @@ environment:

matrix:
# Install tests:
- nodejs_version: '12'
npm_version: '>2.7.0'
BUILD_TASK: 'test-npm-install'
- nodejs_version: '11'
npm_version: '>2.7.0'
BUILD_TASK: 'test-npm-install'
@@ -82,6 +85,9 @@ environment:
BUILD_TASK: 'test-npm-install'

# Unit tests:
- nodejs_version: '12'
npm_version: '>2.7.0'
BUILD_TASK: 'test'
- nodejs_version: '11'
npm_version: '>2.7.0'
BUILD_TASK: 'test'
@@ -114,6 +120,9 @@ environment:
BUILD_TASK: 'test'

# Examples:
- nodejs_version: '12'
npm_version: '>2.7.0'
BUILD_TASK: 'examples'
- nodejs_version: '11'
npm_version: '>2.7.0'
BUILD_TASK: 'examples'
@@ -146,6 +155,9 @@ environment:
BUILD_TASK: 'examples'

# Test coverage:
- nodejs_version: '12'
npm_version: '>2.7.0'
BUILD_TASK: 'test-coverage'
- nodejs_version: '11'
npm_version: '>2.7.0'
BUILD_TASK: 'test-coverage'
@@ -178,6 +190,9 @@ environment:
BUILD_TASK: 'test-coverage'

# Benchmarks:
- nodejs_version: '12'
npm_version: '>2.7.0'
BUILD_TASK: 'benchmark'
- nodejs_version: '11'
npm_version: '>2.7.0'
BUILD_TASK: 'benchmark'
@@ -28,7 +28,7 @@ endif
# GENERAL VARIABLES #

# Define supported Node.js versions:
NODE_VERSIONS ?= '0.10 0.12 1 2 3 4 5 6 7 8 9 10 11 node'
NODE_VERSIONS ?= '0.10 0.12 1 2 3 4 5 6 7 8 9 10 11 12 node'

# Define a license SPDX identifier whitelist:
LICENSES_WHITELIST ?= 'Apache-2.0,Artistic-2.0,BSD-2-Clause,BSD-3-Clause,BSL-1.0,CC0-1.0,ISC,MIT,MPL-2.0,Unlicense,WTFPL'
@@ -36,7 +36,7 @@
# VARIABLES #

# Define the Node.js versions:
versions=(0.10 0.12 1 2 3 4 5 6 7 8 9 10 11 node)
versions=(0.10 0.12 1 2 3 4 5 6 7 8 9 10 11 12 node)

# Set a flag indicating whether to perform a fresh install of node module dependencies for each Node.js version:
install_deps=false

0 comments on commit 12035de

Please sign in to comment.
You can’t perform that action at this time.