Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 127 lines (121 sloc) 5.078 kB
9bce98f @danmayer updated bundler and rakefile
danmayer authored
1 # Generated by jeweler
2 # DO NOT EDIT THIS FILE DIRECTLY
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
3 # Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
9bce98f @danmayer updated bundler and rakefile
danmayer authored
4 # -*- encoding: utf-8 -*-
5
6 Gem::Specification.new do |s|
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
7 s.name = "churn"
8 s.version = "0.0.14"
9bce98f @danmayer updated bundler and rakefile
danmayer authored
9
10 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
11 s.authors = ["Dan Mayer"]
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
12 s.date = "2011-10-30"
13 s.description = "High method and class churn has been shown to have increased bug and error rates. This gem helps you know what is changing a lot so you can do additional testing, code review, or refactoring to try to tame the volatile code. "
14 s.email = "dan@mayerdan.com"
9bce98f @danmayer updated bundler and rakefile
danmayer authored
15 s.executables = ["churn"]
16 s.extra_rdoc_files = [
17 "LICENSE",
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
18 "README.rdoc"
9bce98f @danmayer updated bundler and rakefile
danmayer authored
19 ]
20 s.files = [
21 ".document",
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
22 "Gemfile",
23 "Gemfile.lock",
24 "LICENSE",
25 "README.rdoc",
26 "Rakefile",
27 "VERSION",
28 "bin/churn",
29 "churn.gemspec",
30 "lib/churn.rb",
31 "lib/churn/bzr_analyzer.rb",
32 "lib/churn/churn_calculator.rb",
33 "lib/churn/churn_history.rb",
34 "lib/churn/git_analyzer.rb",
35 "lib/churn/hg_analyzer.rb",
36 "lib/churn/location_mapping.rb",
37 "lib/churn/source_control.rb",
38 "lib/churn/svn_analyzer.rb",
39 "lib/tasks/churn_tasks.rb",
40 "man/churn.1",
41 "man/churn.html",
9bce98f @danmayer updated bundler and rakefile
danmayer authored
42 "test/data/churn_calculator.rb",
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
43 "test/data/test_helper.rb",
44 "test/test_helper.rb",
45 "test/unit/bzr_analyzer_test.rb",
46 "test/unit/churn_calculator_test.rb",
47 "test/unit/churn_history_test.rb",
48 "test/unit/git_analyzer_test.rb",
49 "test/unit/hg_analyzer_test.rb",
50 "test/unit/location_mapping_test.rb"
9bce98f @danmayer updated bundler and rakefile
danmayer authored
51 ]
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
52 s.homepage = "http://github.com/danmayer/churn"
53 s.require_paths = ["lib"]
54 s.rubygems_version = "1.8.10"
55 s.summary = "Providing additional churn metrics over the original metric_fu churn"
9bce98f @danmayer updated bundler and rakefile
danmayer authored
56
57 if s.respond_to? :specification_version then
58 s.specification_version = 3
59
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
60 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
61 s.add_runtime_dependency(%q<arrayfields>, ["= 4.7.4"])
62 s.add_runtime_dependency(%q<chronic>, ["= 0.6.4"])
63 s.add_runtime_dependency(%q<fattr>, ["= 2.2.0"])
64 s.add_runtime_dependency(%q<hirb>, ["= 0.5.0"])
65 s.add_runtime_dependency(%q<jeweler>, ["= 1.6.4"])
66 s.add_runtime_dependency(%q<json>, ["= 1.6.1"])
67 s.add_runtime_dependency(%q<main>, ["= 4.7.7"])
68 s.add_runtime_dependency(%q<map>, ["= 4.3.0"])
69 s.add_runtime_dependency(%q<ruby_parser>, ["= 2.3.1"])
70 s.add_runtime_dependency(%q<sexp_processor>, ["= 3.0.7"])
9bce98f @danmayer updated bundler and rakefile
danmayer authored
71 s.add_development_dependency(%q<shoulda>, [">= 0"])
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
72 s.add_development_dependency(%q<jeweler>, ["~> 1.6.0"])
9bce98f @danmayer updated bundler and rakefile
danmayer authored
73 s.add_development_dependency(%q<test-construct>, [">= 0"])
74 s.add_development_dependency(%q<mocha>, ["~> 0.9.5"])
75 s.add_runtime_dependency(%q<main>, [">= 0"])
76 s.add_runtime_dependency(%q<json_pure>, [">= 0"])
77 s.add_runtime_dependency(%q<chronic>, [">= 0.2.3"])
78 s.add_runtime_dependency(%q<sexp_processor>, ["~> 3.0.3"])
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
79 s.add_runtime_dependency(%q<ruby_parser>, ["~> 2.3"])
9bce98f @danmayer updated bundler and rakefile
danmayer authored
80 s.add_runtime_dependency(%q<hirb>, [">= 0"])
81 else
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
82 s.add_dependency(%q<arrayfields>, ["= 4.7.4"])
83 s.add_dependency(%q<chronic>, ["= 0.6.4"])
84 s.add_dependency(%q<fattr>, ["= 2.2.0"])
85 s.add_dependency(%q<hirb>, ["= 0.5.0"])
86 s.add_dependency(%q<jeweler>, ["= 1.6.4"])
87 s.add_dependency(%q<json>, ["= 1.6.1"])
88 s.add_dependency(%q<main>, ["= 4.7.7"])
89 s.add_dependency(%q<map>, ["= 4.3.0"])
90 s.add_dependency(%q<ruby_parser>, ["= 2.3.1"])
91 s.add_dependency(%q<sexp_processor>, ["= 3.0.7"])
9bce98f @danmayer updated bundler and rakefile
danmayer authored
92 s.add_dependency(%q<shoulda>, [">= 0"])
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
93 s.add_dependency(%q<jeweler>, ["~> 1.6.0"])
9bce98f @danmayer updated bundler and rakefile
danmayer authored
94 s.add_dependency(%q<test-construct>, [">= 0"])
95 s.add_dependency(%q<mocha>, ["~> 0.9.5"])
96 s.add_dependency(%q<main>, [">= 0"])
97 s.add_dependency(%q<json_pure>, [">= 0"])
98 s.add_dependency(%q<chronic>, [">= 0.2.3"])
99 s.add_dependency(%q<sexp_processor>, ["~> 3.0.3"])
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
100 s.add_dependency(%q<ruby_parser>, ["~> 2.3"])
9bce98f @danmayer updated bundler and rakefile
danmayer authored
101 s.add_dependency(%q<hirb>, [">= 0"])
102 end
103 else
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
104 s.add_dependency(%q<arrayfields>, ["= 4.7.4"])
105 s.add_dependency(%q<chronic>, ["= 0.6.4"])
106 s.add_dependency(%q<fattr>, ["= 2.2.0"])
107 s.add_dependency(%q<hirb>, ["= 0.5.0"])
108 s.add_dependency(%q<jeweler>, ["= 1.6.4"])
109 s.add_dependency(%q<json>, ["= 1.6.1"])
110 s.add_dependency(%q<main>, ["= 4.7.7"])
111 s.add_dependency(%q<map>, ["= 4.3.0"])
112 s.add_dependency(%q<ruby_parser>, ["= 2.3.1"])
113 s.add_dependency(%q<sexp_processor>, ["= 3.0.7"])
9bce98f @danmayer updated bundler and rakefile
danmayer authored
114 s.add_dependency(%q<shoulda>, [">= 0"])
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
115 s.add_dependency(%q<jeweler>, ["~> 1.6.0"])
9bce98f @danmayer updated bundler and rakefile
danmayer authored
116 s.add_dependency(%q<test-construct>, [">= 0"])
117 s.add_dependency(%q<mocha>, ["~> 0.9.5"])
118 s.add_dependency(%q<main>, [">= 0"])
119 s.add_dependency(%q<json_pure>, [">= 0"])
120 s.add_dependency(%q<chronic>, [">= 0.2.3"])
121 s.add_dependency(%q<sexp_processor>, ["~> 3.0.3"])
ade042a @danmayer Regenerate gemspec for version 0.0.14
danmayer authored
122 s.add_dependency(%q<ruby_parser>, ["~> 2.3"])
9bce98f @danmayer updated bundler and rakefile
danmayer authored
123 s.add_dependency(%q<hirb>, [">= 0"])
124 end
125 end
126
Something went wrong with that request. Please try again.