Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
executable file 98 lines (98 sloc) 2.97 KB
{
"name": "steamer-simple",
"version": "4.0.0",
"description": "alloyteam frameworkless starterkit",
"main": "./.steamer/steamer-simple.js",
"scripts": {
"start": "cross-env NODE_ENV=development node ./tools/script.js",
"dev": "npm run start",
"dist": "cross-env NODE_ENV=production node ./tools/script.js",
"pub": "npm run dist",
"test": "",
"lint": "eslint src & stylelint src/**/*.less",
"lint:js": "eslint src",
"lint:style": "stylelint src/**/*.less"
},
"repository": {
"type": "git",
"url": "git+https://github.com/SteamerTeam/steamer-simple.git"
},
"keywords": [
"steamer starterkit",
"simple",
"webpack",
"steamerjs",
"boilerplate",
"starter-kit"
],
"author": "SteamerTeam",
"license": "MIT",
"bugs": {
"url": "https://github.com/SteamerTeam/steamer-simple/issues"
},
"homepage": "https://github.com/SteamerTeam/steamer-simple#readme",
"browserslist": [
"last 8 versions"
],
"dependencies": {},
"devDependencies": {
"@alloyteam/eslint-config-standard": "0.0.9",
"@alloyteam/stylelint-config-standard": "0.0.2",
"autoprefixer": "^9.1.3",
"babel-core": "^6.26.3",
"babel-eslint": "^8.2.6",
"babel-loader": "^7.1.5",
"babel-plugin-syntax-dynamic-import": "^6.18.0",
"babel-plugin-transform-decorators-legacy": "^1.3.5",
"babel-plugin-transform-runtime": "^6.23.0",
"babel-preset-es2015": "^6.24.1",
"babel-runtime": "^6.26.0",
"browserslist": "^4.1.0",
"cache-loader": "^1.2.2",
"caniuse-db": "^1.0.30000878",
"clean-webpack-plugin": "^0.1.19",
"copy-webpack-plugin-hash": "^6.0.0",
"cross-env": "^5.2.0",
"css-loader": "^1.0.0",
"eslint": "^5.4.0",
"eslint-config-alloy": "^1.4.2",
"exports-loader": "^0.7.0",
"expose-loader": "^0.7.5",
"express": "^4.16.3",
"extract-text-webpack-plugin": "^3.0.2",
"file-loader": "^2.0.0",
"file-webpack-plugin": "^2.0.0",
"happypack": "^5.0.0",
"html-loader": "^0.5.5",
"html-res-webpack-plugin": "^4.0.4",
"http-proxy-middleware": "^0.18.0",
"imports-loader": "^0.8.0",
"less": "^3.8.1",
"less-loader": "^4.1.0",
"lodash.merge": "^4.6.1",
"mini-css-extract-plugin": "^0.4.2",
"name-all-modules-plugin": "^1.0.1",
"optimize-css-assets-webpack-plugin": "^5.0.0",
"postcss-assets": "^5.0.0",
"postcss-import": "^12.0.0",
"postcss-loader": "^3.0.0",
"spritesheet-templates-steamer": "^1.0.2",
"steamer-browserutils": "^2.0.0",
"steamer-webpack-utils": "^1.1.0",
"style-loader": "^0.22.1",
"stylelint": "^9.5.0",
"uglifyjs-webpack-plugin": "^1.3.0",
"url-loader": "^1.1.1",
"vconsole": "^3.2.0",
"webpack": "^4.17.1",
"webpack-dev-middleware": "^3.2.0",
"webpack-hot-middleware": "^2.22.3",
"webpack-manifest-plugin": "^2.0.3",
"webpack-merge": "^4.1.4",
"webpack-spritesmith": "^0.5.2",
"write-file-webpack-plugin": "^4.3.2"
},
"engines": {
"node": ">=6.10.0"
}
}
You can’t perform that action at this time.