Error with activesupport installing ancestry with Ruby 1.8.7 and Rails 2.3.14 #156

Open
osnysantos opened this Issue Sep 19, 2013 · 4 comments

Comments

Projects
None yet
3 participants
@osnysantos

I'm installing folowwing the docs:

  1. Add to config/environment.rb: config.gem ‘ancestry’
  2. Install required gems: sudo rake gems:install

But in step 2, I got this message:

✗ sudo rake gems:install
rake/rdoctask is deprecated. Use rdoc/task instead (in RDoc 2.4.2+)
Please install RDoc 2.4.2+ to generate documentation.
DEPRECATION WARNING: Rake tasks in vendor/plugins/active_record_tableless/tasks, vendor/plugins/asset_packager/tasks, vendor/plugins/backgroundrb/tasks, vendor/plugins/recaptcha/tasks, and vendor/plugins/without_callbacks/tasks are deprecated. Use lib/tasks instead. (called from /Users/netto/.rvm/rubies/ree-1.8.7-2012.02/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/tasks/rails.rb:10)
gem install ancestry --version ">= 0"
ERROR: Error installing ancestry:
activesupport requires Ruby version >= 1.9.3.
Building native extensions. This could take a while...
Loaded suite /Users/netto/.rvm/gems/ree-1.8.7-2012.02/bin/rake
Started

Finished in 0.000194 seconds.

0 tests, 0 assertions, 0 failures, 0 errors

I dont know why activesupport requires Ruby >= 1.9.3, I'm using Rails 2.3.14 and Ruby 1.8.7 support Rails 2.3 as I know.

@josecoelho

This comment has been minimized.

Show comment Hide comment
@josecoelho

josecoelho Nov 4, 2013

+1

+1

@josecoelho

This comment has been minimized.

Show comment Hide comment
@josecoelho

josecoelho Nov 4, 2013

Fixed!

You should require ancestry on config/enviroment.rb:

require 'ancestry'

Fixed!

You should require ancestry on config/enviroment.rb:

require 'ancestry'

@amanbop

This comment has been minimized.

Show comment Hide comment
@amanbop

amanbop Aug 7, 2014

I am still facing this issue while installing with rails 3.0.7

ruby -v
ruby 1.8.7 (2013-06-27 patchlevel 374) [i386-mingw32]

gem list rails

*** LOCAL GEMS ***

rails (3.0.7)

gem install ancestry
ERROR:  Error installing ancestry:
        activesupport requires Ruby version >= 1.9.3.

amanbop commented Aug 7, 2014

I am still facing this issue while installing with rails 3.0.7

ruby -v
ruby 1.8.7 (2013-06-27 patchlevel 374) [i386-mingw32]

gem list rails

*** LOCAL GEMS ***

rails (3.0.7)

gem install ancestry
ERROR:  Error installing ancestry:
        activesupport requires Ruby version >= 1.9.3.
@amanbop

This comment has been minimized.

Show comment Hide comment
@amanbop

amanbop Aug 7, 2014

using bundle to install instead of gem install fixes this issue

amanbop commented Aug 7, 2014

using bundle to install instead of gem install fixes this issue

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment