Skip to content

Jeremy Shaw
stepcut

Organizations

@Happstack @clckwrks @lens @acid-state @seereason @haskell-servant @ChicagoHaskell @stripe-haskell
Jun 29, 2016
@stepcut
Jun 28, 2016
@stepcut
  • df6430b
    explicitly import Instances.TH.Lift to ensure instances are available
Jun 28, 2016
@stepcut
Jun 27, 2016
stepcut commented on issue NixOS/nixpkgs#16542
@stepcut

Ah -- that makes sense, but doesn't solve my problem. In this case I am building with ghcjs-0.2.0 which has not yet been updated to GHC 8.x. I upda…

Jun 27, 2016
@stepcut
haskellPackages.semigroups missing build dependencies
Jun 23, 2016
@stepcut
  • @stepcut 883283b
    .travis.yml - GHC 8.0.1 is no longer allowed to fail
Jun 23, 2016
@stepcut
  • @stepcut 31ad9ca
    .travis.yml - do not test on GHC 7.8.4 anymore
Jun 23, 2016
@stepcut
  • @stepcut 1554523
    .travis.yml: do not test on 7.8.4 anymore due to jwt failing to install
Jun 23, 2016
@stepcut
  • @stepcut d879b32
    .travis.yml - add happy to $PATH
Jun 23, 2016
@stepcut
  • @stepcut 30045ef
    .travis.yml - add happy to $PATH
Jun 23, 2016
@stepcut
  • @stepcut 25f38cf
    .travis.yml - include happy in build environment. fix source location…
Jun 23, 2016
@stepcut
  • @stepcut d4a8a28
    .travis.yml - include happy in the build environment
Jun 23, 2016
@stepcut
  • @stepcut db92b36
    start testing with GHC 8.0.1
Jun 23, 2016
@stepcut
  • @stepcut 61bd527
    regenerate .travis.yml, modernize .cabal
Jun 23, 2016
stepcut opened pull request fpco/stackage#1642
@stepcut
renabled ixset and clckwrks for GHC 8
1 commit with 8 additions and 8 deletions
Jun 23, 2016
@stepcut
  • @stepcut 2938146
    renabled ixset and clckwrks for GHC 8
Jun 23, 2016
Jun 23, 2016
@stepcut
  • @stepcut 2313504
    .travis.yml - use cabal-install-1.24 with GHC 8.0 build
Jun 22, 2016
@stepcut
  • @stepcut eeb21e3
    .travis.yml: allow 7.8.3 to fail
Jun 22, 2016
@stepcut
  • @stepcut 7fd1540
    .travis.yml - disable cabal tests since we do not have any and it bre…
Jun 22, 2016
@stepcut
Jun 22, 2016
@stepcut
  • @stepcut e0a308f
    same as before, but working this time
Jun 22, 2016
@stepcut
  • @stepcut 28f034a
    .travis.yml - attempt to fix version mismatch for cabal
Jun 22, 2016
@stepcut
  • @stepcut 9dbfaec
    .travis.yml GHC 8.0.1 no longer allowed to fail.
Jun 22, 2016
@stepcut
Jun 22, 2016
@stepcut
  • @stepcut ebdda93
    0.4.2 - allow base 4.9. start testing on travis.
Jun 22, 2016
@stepcut
Jun 22, 2016
@stepcut
  • @stepcut 827d2f8
    test with GHC 8.0.1, 7.10.2, 7.8.4 and 7.6.3
Jun 12, 2016
@stepcut
  • @stepcut f940fa8
    0.4.2 - start testing with 8.0.1
Jun 12, 2016
@stepcut
  • @stepcut bb12923
    0.4.3.3 - allow tagsoup 0.14
Something went wrong with that request. Please try again.