Skip to content

brew install io fails on Mountain Lion #223

Closed
eudyptes opened this Issue Jul 25, 2012 · 14 comments

9 participants

@eudyptes

Trying to install Io using homebrew on Mountain Lion (OSX 10.8).

While doing the "make" step of the install of Io itself, the build seems to hang while running the command:

../../_build/binaries/io_static /tmp/homebrew-io-2011.09.12-fHKY/stevedekorte-io-23afbcc/addons/generate.io /tmp/homebrew-io-2011.09.12-fHKY/stevedekorte-io-23afbcc/addons AsyncRequest

The full ps listing is:

dhcp-51:~ craiga$ ps -ww
PID TTY TIME CMD
77934 ttys000 0:00.01 -bash
78000 ttys000 0:00.05 /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby /usr/local/bin/brew install io
78021 ttys000 0:00.13 /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby -I /usr/local/Library/Homebrew -rbuild -- /usr/local/Library/Formula/io.rb
78174 ttys000 0:00.01 make
78179 ttys000 0:00.03 make -f CMakeFiles/Makefile2 all
79311 ttys000 0:00.00 make -f addons/AsyncRequest/CMakeFiles/IoAsyncRequest.dir/build.make addons/AsyncRequest/CMakeFiles/IoAsyncRequest.dir/depend
79314 ttys000 0:00.00 /bin/sh -c cd /tmp/homebrew-io-2011.09.12-fHKY/stevedekorte-io-23afbcc/buildroot/addons/AsyncRequest && ../../_build/binaries/io_static /tmp/homebrew-io-2011.09.12-fHKY/stevedekorte-io-23afbcc/addons/generate.io /tmp/homebrew-io-2011.09.12-fHKY/stevedekorte-io-23afbcc/addons AsyncRequest
79315 ttys000 14:31.23 ../../_build/binaries/io_static /tmp/homebrew-io-2011.09.12-fHKY/stevedekorte-io-23afbcc/addons/generate.io /tmp/homebrew-io-2011.09.12-fHKY/stevedekorte-io-23afbcc/addons AsyncRequest
79341 ttys001 0:00.02 -bash

@ghost
ghost commented Jul 30, 2012

I have the same issue trying to build io on 10.8. The build hangs on the AsyncRequest step.

@ghost
ghost commented Jul 30, 2012

I managed to get io to build on Mountain Lion by first installing gcc:

brew install https://raw.github.com/Homebrew/homebrew-dupes/master/apple-gcc42.rb

and then installing Io using the --use-gcc flag:

brew install --use-gcc io
@miguelbaldi

Same problem here. @HelgeG suggestion worked for me.

@jefflembeck

Same problem here. @HelgeG suggestion worked as well.

@sarvex
sarvex commented Aug 15, 2012

I encountered the same problem, and i did not want to install complete gcc (that too not the latest 4.7)

--use-llvm

For me the compilation finished successfully by using llvm

@gauravagarwalr

@sarvex Worked for me.. Thank you! :)

@zeckalpha

Same issue for OS X 10.7, and --use-llvm did work.

@zeckalpha zeckalpha referenced this issue in Homebrew/legacy-homebrew Sep 15, 2012
Closed

io fails_with :clang #14951

@zeckalpha

I added a fails_with :clang to the formula Homebrew/legacy-homebrew#14951

@ngarneau
ngarneau commented Oct 5, 2012

Using llvm worked perfectly for me, else make was hanging

@zeckalpha

To clarify, else make with --use-llvm or else make with --use-clang?

@prologic

Works for me on:

  • OS X 10.8.4
  • XCode 4.6.3

cheers
James

@zeckalpha

Anyone still having problems?

@simeonwillbanks simeonwillbanks pushed a commit to simeonwillbanks/homebrew that referenced this issue Oct 30, 2013
@zeckalpha zeckalpha io fails_with :clang
make never completes. see: stevedekorte/io#223

I've never put in a fails_with before, so this could be wrong.

Closes #14951.

Signed-off-by: Adam Vandenberg <flangy@gmail.com>
c3c4496
@zeckalpha

Now I'm having problems again. I'll look into them tomorrow. If they're related, I'll add them here, but if they are different, I'll open a new issue and I vote we close this one.

@zeckalpha

It seems to be a different issue. Can we close this one?

@zeckalpha zeckalpha referenced this issue in Homebrew/legacy-homebrew Dec 18, 2013
Closed

io failed to build on 10.9 #25315

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.