Ensure net/https uses OpenSSL::SSL::VERIFY_PEER to verify SSL certificates and provides certificate bundle in case OpenSSL cannot find one
Ruby
Switch branches/tags
Nothing to show
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
bin certified-update Jul 18, 2014
certs Update cert bundle. Jul 18, 2014
LICENSE add MIT license Nov 19, 2014
README.md certified-update Jul 18, 2014
certified.gemspec add MIT license Nov 19, 2014
certified.rb Fix Faraday with default (Net::HTTP) adapter Jan 21, 2014

README.md

Certified

HEY!

Always remember to keep your certificate bundle up to date using the included certified-update executable!

Solves http://martinottenwaelter.fr/2010/12/ruby19-and-the-ssl-error/ by providing a crt bundle and explicitly telling Ruby where to find it. Also forces OpenSSL::SSL::VERIFY_PEER

gem install certified