Skip to content
Browse files

Don't require 'rspec' at runtime

Because it is assumed the gem is used in the context of rspec itself it
is unecessary to require the 'rspec' gem.

This is important because of a recent change to 'rspec-rails'. That gem
no longer installs 'rspec' itself:
rspec/rspec-rails@f5a5735
  • Loading branch information...
1 parent f06afae commit aa07dc1f86e1a803b2115bc1064871debf96005b @bcardarella bcardarella committed Dec 2, 2012
Showing with 1 addition and 2 deletions.
  1. +1 −2 lib/generator_spec/test_case.rb
View
3 lib/generator_spec/test_case.rb
@@ -1,5 +1,4 @@
require 'active_record'
-require 'rspec'
require 'rails/generators/test_case'
require 'generator_spec/matcher'
@@ -46,4 +45,4 @@ def respond_to?(method_sym, include_private = false)
end
end
end
-end
+end

0 comments on commit aa07dc1

Please sign in to comment.
Something went wrong with that request. Please try again.