Permalink
Browse files

Downgrade to cucumber-rails 0.3.2 and webrat 0.5.3

I spent a day trying to get the cukes passing with the latest version of
these gems and failed miserably. Perhaps someone else can try again in
the future. I've created an issue so it doesn't get forgotten: #314
  • Loading branch information...
sferik committed Jul 17, 2011
1 parent 81f10f7 commit 9f47f602f9c8bd019a56cd93a9a986ecffbbe4b3
View
@@ -40,16 +40,15 @@ group :development, :test do
end
group :test do
- gem 'cucumber-rails'
+ gem 'cucumber-rails', '~> 0.3.2'
gem 'database_cleaner'
gem 'factory_girl_rails'
gem 'launchy'
gem 'nokogiri'
gem 'rack-test', :require => 'rack/test'
gem 'rr'
- gem 'selenium-rc'
gem 'shoulda'
gem 'timecop'
gem 'webmock'
- gem 'webrat'
+ gem 'webrat', '~> 0.5.3'
end
View
@@ -32,15 +32,6 @@ GEM
arel (2.0.10)
bouncy-castle-java (1.5.0146.1)
builder (2.1.2)
- capybara (1.0.0)
- mime-types (>= 1.16)
- nokogiri (>= 1.3.3)
- rack (>= 1.0.0)
- rack-test (>= 0.5.4)
- selenium-webdriver (~> 0.2.0)
- xpath (~> 0.1.4)
- childprocess (0.1.9)
- ffi (~> 1.0.6)
clearance (0.9.1)
rails (~> 3.0.0)
crack (0.1.8)
@@ -50,10 +41,8 @@ GEM
gherkin (~> 2.4.5)
json (>= 1.4.6)
term-ansicolor (>= 1.0.5)
- cucumber-rails (1.0.2)
- capybara (>= 1.0.0)
- cucumber (~> 1.0.0)
- nokogiri (>= 1.4.6)
+ cucumber-rails (0.3.2)
+ cucumber (>= 0.8.0)
daemons (1.1.4)
database_cleaner (0.6.7)
delayed_job (2.1.4)
@@ -67,8 +56,6 @@ GEM
factory_girl_rails (1.0.1)
factory_girl (~> 1.3)
railties (>= 3.0.0)
- ffi (1.0.9)
- ffi (1.0.9-java)
fog (0.9.0)
builder
excon (~> 0.6.1)
@@ -95,7 +82,6 @@ GEM
bouncy-castle-java
json (1.5.3)
json (1.5.3-java)
- json_pure (1.5.3)
launchy (2.0.1)
launchy (2.0.1-java)
spoon (~> 0.0.1)
@@ -143,20 +129,11 @@ GEM
mime-types (>= 1.16)
rr (1.0.3)
ruby-hmac (0.4.0)
- rubyzip (0.9.4)
- selenium-client (1.2.18)
- selenium-rc (2.4.0)
- selenium-client (>= 1.2.18)
- selenium-webdriver (0.2.2)
- childprocess (>= 0.1.9)
- ffi (>= 1.0.7)
- json_pure
- rubyzip
shoulda (2.11.3)
silent-postgres (0.0.8)
sinatra (1.2.6)
rack (~> 1.1)
- tilt (< 2.0, >= 1.2.2)
+ tilt (>= 1.2.2, < 2.0)
spoon (0.0.1)
system_timer (1.2.4)
term-ansicolor (1.0.5)
@@ -169,16 +146,13 @@ GEM
validates_url_format_of (0.1.0)
activerecord (>= 2.3.4)
webmock (1.6.4)
- addressable (> 2.2.5, ~> 2.2)
+ addressable (~> 2.2, > 2.2.5)
crack (>= 0.1.7)
- webrat (0.7.3)
+ webrat (0.5.3)
nokogiri (>= 1.2.0)
rack (>= 1.0)
- rack-test (>= 0.5.3)
will_paginate (3.0.pre2)
xml-simple (1.1.0)
- xpath (0.1.4)
- nokogiri (~> 1.3)
yajl-ruby (0.8.2)
PLATFORMS
@@ -187,7 +161,7 @@ PLATFORMS
DEPENDENCIES
clearance (~> 0.9.1)
- cucumber-rails
+ cucumber-rails (~> 0.3.2)
database_cleaner
delayed_job
factory_girl_rails
@@ -210,15 +184,14 @@ DEPENDENCIES
redis
rest-client
rr
- selenium-rc
shoulda
silent-postgres
sinatra
system_timer
timecop
validates_url_format_of
webmock
- webrat
+ webrat (~> 0.5.3)
will_paginate (~> 3.0.pre2)
xml-simple
yajl-ruby
Oops, something went wrong.

0 comments on commit 9f47f60

Please sign in to comment.