Permalink
Browse files

Adding README

  • Loading branch information...
1 parent 1143a48 commit 98985702cbf5d6a5fa8d615a212eee739213cb2d @steveklabnik committed Mar 6, 2011
Showing with 15 additions and 0 deletions.
  1. +15 −0 README.md
View
@@ -0,0 +1,15 @@
+require_relative
+================
+
+In Ruby 1.9.2, "." was removed from the $LOAD_PATH. require_relative was
+added to let you require files relative to your current directory.
+
+This gem backports both of these features to earlier Rubies.
+
+## Usage
+
+ require 'rubygems'
+ require 'require_relative'
+
+ require 'foo' #=> LoadError
+ require_relative 'foo' #=> works!

2 comments on commit 9898570

nobu commented on 9898570 Jun 19, 2011

It's not relative to "current directory", but to the directory of the caller file.

Owner

Word. Wanna fork and 'edit on github' to change that, so I can give you credit?

Please sign in to comment.