Skip to content
This backports require_relative to Ruby 1.8.
Ruby Shell
Find file
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
lib
test
.gitignore
.rvmrc
Gemfile
README.md
Rakefile
require_relative.gemspec

README.md

require_relative

In Ruby 1.9.2, "." was removed from the $LOAD_PATH. require_relative was added to let you require files relative to your current directory.

This gem backports both of these features to earlier Rubies.

Usage

require 'rubygems'
require 'require_relative'

require 'foo' #=> LoadError
require_relative 'foo' #=> works!
Something went wrong with that request. Please try again.