Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Fixing generated initializer #3

Merged
merged 1 commit into from

2 participants

@chip-miller

Hey Steven,
Great work on this gem. I got error after running koala:install (uninitialized constant Facebook::RAILS_ROOT) with rails 3.1.3. Quick fix - here you go.

-- Chip

Chip Miller Updating generated initializer to use Rails.root
In order to avoid: uninitialized constant Facebook::RAILS_ROOT
835549c
@stevenh512 stevenh512 merged commit 9594e18 into stevenh512:master
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Dec 15, 2011
  1. Updating generated initializer to use Rails.root

    Chip Miller authored
    In order to avoid: uninitialized constant Facebook::RAILS_ROOT
This page is out of date. Refresh to see the latest.
View
2  lib/generators/koala/install/templates/config/initializers/koala.rb.tt
@@ -5,7 +5,7 @@
require "koala"
module Facebook
- CONFIG = YAML.load(ERB.new(File.read("#{RAILS_ROOT}/config/facebook.yml")).result)[Rails.env]
+ CONFIG = YAML.load(ERB.new(File.read("#{Rails.root}/config/facebook.yml")).result)[Rails.env]
APP_ID = CONFIG['app_id']
SECRET = CONFIG['secret']
end
Something went wrong with that request. Please try again.