Browse files

upped version, changed dep list in readme and rakefile, added changes…

… to changelog
  • Loading branch information...
1 parent 2733d93 commit 94a08fc429bd54b53cd8225a06b15f316bcced0c @tpitale tpitale committed Mar 25, 2010
Showing with 15 additions and 11 deletions.
  1. +4 −0 CHANGELOG.md
  2. +1 −1 README.md
  3. +1 −1 Rakefile
  4. +8 −8 garb.gemspec
  5. +1 −1 lib/garb/version.rb
View
4 CHANGELOG.md
@@ -1,3 +1,7 @@
+Version 0.7.4
+
+ * Removes HappyMapper dependency in favor of Crack so we can drop libxml dependency
+
Version 0.7.0
* Adds multi-session support
View
2 README.md
@@ -200,7 +200,7 @@ TODOS
Requirements
------------
- * happymapper >= 0.3.0
+ * crack >= 0.1.6
* active_support >= 2.2.0
Requirements for Testing
View
2 Rakefile
@@ -18,7 +18,7 @@ spec = Gem::Specification.new do |s|
s.files = %w(README.md Rakefile) + Dir.glob("lib/**/*")
s.test_files = Dir.glob("test/**/*")
- s.add_dependency("happymapper", [">= 0.3.0"])
+ s.add_dependency("crack", [">= 0.1.6"])
s.add_dependency("activesupport", [">= 2.2.0"])
end
View
16 garb.gemspec
@@ -2,11 +2,11 @@
Gem::Specification.new do |s|
s.name = %q{garb}
- s.version = "0.7.3"
+ s.version = "0.7.4"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Tony Pitale"]
- s.date = %q{2010-03-18}
+ s.date = %q{2010-03-25}
s.email = %q{tony.pitale@viget.com}
s.files = ["README.md", "Rakefile", "lib/garb", "lib/garb/account.rb", "lib/garb/authentication_request.rb", "lib/garb/data_request.rb", "lib/garb/filter_parameters.rb", "lib/garb/profile.rb", "lib/garb/profile_reports.rb", "lib/garb/report.rb", "lib/garb/report_parameter.rb", "lib/garb/report_response.rb", "lib/garb/reports", "lib/garb/reports/bounces.rb", "lib/garb/reports/exits.rb", "lib/garb/reports/pageviews.rb", "lib/garb/reports/unique_pageviews.rb", "lib/garb/reports/visits.rb", "lib/garb/reports.rb", "lib/garb/resource.rb", "lib/garb/session.rb", "lib/garb/version.rb", "lib/garb.rb", "lib/support.rb", "test/fixtures", "test/fixtures/cacert.pem", "test/fixtures/profile_feed.xml", "test/fixtures/report_feed.xml", "test/test_helper.rb", "test/unit", "test/unit/garb", "test/unit/garb/account_test.rb", "test/unit/garb/authentication_request_test.rb", "test/unit/garb/data_request_test.rb", "test/unit/garb/filter_parameters_test.rb", "test/unit/garb/oauth_session_test.rb", "test/unit/garb/profile_reports_test.rb", "test/unit/garb/profile_test.rb", "test/unit/garb/report_parameter_test.rb", "test/unit/garb/report_response_test.rb", "test/unit/garb/report_test.rb", "test/unit/garb/resource_test.rb", "test/unit/garb/session_test.rb", "test/unit/garb_test.rb", "test/unit/symbol_operator_test.rb"]
s.has_rdoc = false
@@ -22,14 +22,14 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<happymapper>, [">= 0.3.0"])
- s.add_runtime_dependency(%q<activesupport>, [">= 2.3.0"])
+ s.add_runtime_dependency(%q<crack>, [">= 0.1.6"])
+ s.add_runtime_dependency(%q<activesupport>, [">= 2.2.0"])
else
- s.add_dependency(%q<happymapper>, [">= 0.3.0"])
- s.add_dependency(%q<activesupport>, [">= 2.3.0"])
+ s.add_dependency(%q<crack>, [">= 0.1.6"])
+ s.add_dependency(%q<activesupport>, [">= 2.2.0"])
end
else
- s.add_dependency(%q<happymapper>, [">= 0.3.0"])
- s.add_dependency(%q<activesupport>, [">= 2.3.0"])
+ s.add_dependency(%q<crack>, [">= 0.1.6"])
+ s.add_dependency(%q<activesupport>, [">= 2.2.0"])
end
end
View
2 lib/garb/version.rb
@@ -3,7 +3,7 @@ module Version
MAJOR = 0
MINOR = 7
- TINY = 3
+ TINY = 4
def self.to_s # :nodoc:
[MAJOR, MINOR, TINY].join('.')

0 comments on commit 94a08fc

Please sign in to comment.