Skip to content
This repository
tag: rel_0_3
Fetching contributors…

Cannot retrieve contributors at this time

file 15 lines (12 sloc) 0.714 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
require File.join(%w{declarative_authorization rails_legacy})
require File.join(%w{declarative_authorization helper})
require File.join(%w{declarative_authorization in_controller})
require File.join(%w{declarative_authorization in_model})
require File.join(%w{declarative_authorization obligation_scope})

min_rails_version = "2.1.0"
if Rails::VERSION::STRING < min_rails_version
  raise "declarative_authorization requires Rails #{min_rails_version}. You are using #{Rails::VERSION::STRING}."
end

ActionController::Base.send :include, Authorization::AuthorizationInController
ActionController::Base.helper Authorization::AuthorizationHelper

ActiveRecord::Base.send :include, Authorization::AuthorizationInModel
Something went wrong with that request. Please try again.