Don't destructively modify SafeBuffers #110

Merged
merged 1 commit into from Oct 18, 2011

Conversation

Projects
None yet
2 participants
Contributor

urkle commented Aug 13, 2011

When running under Rails 3.0.9 the syntax_highlight helper causes a "cannot modify SafeBuffer" error..

This patch fixes the issue.. (lovingly adapted from https://github.com/nex3/haml/commit/fc5a5cb21de15a7c2fde83d4e06a021b2d86c4f1 )

@stffn stffn added a commit that referenced this pull request Oct 18, 2011

@stffn stffn Merge pull request #110 from urkle/patch-1
Don't destructively modify SafeBuffers
ff03e7e

@stffn stffn merged commit ff03e7e into stffn:master Oct 18, 2011

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment