Permalink
Browse files

stop requiring explicitly active_record in rolify.rb

remove Bundler.require in specs as it doesn't work with gemspec directive in Gemfile
refs #50
  • Loading branch information...
1 parent db20f83 commit 3c1d74c1b05e0bdeba7104d1fd33c5143851071b @EppO EppO committed Apr 5, 2012
Showing with 4 additions and 6 deletions.
  1. +0 −2 lib/rolify.rb
  2. +0 −4 spec/spec_helper.rb
  3. +2 −0 spec/support/adapters/active_record.rb
  4. +2 −0 spec/support/adapters/mongoid.rb
View
@@ -1,5 +1,3 @@
-require 'active_record'
-
require 'rolify/railtie' if defined?(Rails)
require 'rolify/utils'
require 'rolify/role'
View
@@ -1,8 +1,4 @@
require 'rubygems'
-require 'bundler/setup'
-
-require 'mongoid'
-Bundler.require(:default, :development, :test)
require 'rolify'
require 'ammeter/init'
@@ -1,3 +1,5 @@
+require 'active_record'
+
ActiveRecord::Base.establish_connection(:adapter => "sqlite3", :database => ":memory:")
ActiveRecord::Base.extend Rolify
@@ -1,3 +1,5 @@
+require 'mongoid'
+
Mongoid.configure do |config|
config.master = Mongo::Connection.new.db("godfather")
end

0 comments on commit 3c1d74c

Please sign in to comment.