Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

@stimulus/polyfills for non-webpack users #247

Closed
mattwoberts opened this issue Apr 30, 2019 · 2 comments

Comments

Projects
None yet
2 participants
@mattwoberts
Copy link

commented Apr 30, 2019

Hi there

As per the docs here we can use stimulus in a world without webpack (I'm currently building my JS with gulp). All is working well with stimulus, but I need the @stimulus/polyfills polyfils so that I can work with IE11. Since I can't import this, is there any way I can get a polyfill file (like the unpkg stimulus source) that I can use in my web app?

Thanks

@javan

This comment has been minimized.

Copy link
Contributor

commented Apr 30, 2019

Sorry, there's no bundled version of @stimulus/polyfills available. Doesn't mean you have to use webpack though. Perhaps you could integrate a tool like rollup with your gulp pipeline? For example:

Or, here's a quick shell script that'll bundle a stimulus-polyfills.js build for you: https://gist.github.com/javan/b05031b4f77851dd80a6e69495f5888a

@javan javan closed this Apr 30, 2019

@mattwoberts

This comment has been minimized.

Copy link
Author

commented Apr 30, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.