Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Deprecation notice on Symfony 4.2 #394

Open
gabiudrescu opened this issue Mar 11, 2019 · 36 comments
Open

Deprecation notice on Symfony 4.2 #394

gabiudrescu opened this issue Mar 11, 2019 · 36 comments

Comments

@gabiudrescu
Copy link

@gabiudrescu gabiudrescu commented Mar 11, 2019

I've added this bundle as a dependency of a Symfony 4.2 project and started to get deprecation notices like the one below:

A tree builder without a root node is deprecated since Symfony 4.2 and will not be supported anymore in 5.0.

stack:

[▼
  "exception" => SilencedErrorContext {#613 ▼
    +count: 13
    -severity: E_USER_DEPRECATED
    trace: {▼
      /var/www/site/vendor/symfony/config/Definition/Builder/TreeBuilder.php:30 {▶}
      /var/www/site/vendor/stof/doctrine-extensions-bundle/DependencyInjection/Configuration.php:17 {▶}
    }
  }
]
@gabiudrescu

This comment has been minimized.

Copy link
Author

@gabiudrescu gabiudrescu commented Mar 11, 2019

I can see that the problem was solved in master, but without a tag, it forces users to use dev@master.

is there any chance to get this tagged?

@JustBlackBird

This comment has been minimized.

Copy link

@JustBlackBird JustBlackBird commented Mar 24, 2019

@stof Could you please tag a new version with the fix?

@n-osennij

This comment has been minimized.

Copy link

@n-osennij n-osennij commented Mar 29, 2019

No tag?

@emovere

This comment has been minimized.

Copy link

@emovere emovere commented Apr 5, 2019

@stof Could you please tag a new version with the fix?

@mysyfy

This comment has been minimized.

Copy link

@mysyfy mysyfy commented Apr 5, 2019

+1 for tag please!

@teian

This comment has been minimized.

Copy link

@teian teian commented Apr 12, 2019

a Tag would be very much appreciated

@BoShurik

This comment has been minimized.

Copy link

@BoShurik BoShurik commented Apr 16, 2019

Just a friendly reminder for @stof to tag a release :-)

@Ciloe

This comment has been minimized.

Copy link

@Ciloe Ciloe commented Apr 18, 2019

I @stof can you tag a new minor version with the fix please ? 🎁 👍 🥇 🙏

@n-osennij

This comment has been minimized.

Copy link

@n-osennij n-osennij commented Apr 18, 2019

It is so sad that me have to wait so long. This is very bad... 😒

@Mvannes

This comment has been minimized.

Copy link

@Mvannes Mvannes commented May 1, 2019

A tag would be lovely!

@tarlepp

This comment has been minimized.

Copy link
Contributor

@tarlepp tarlepp commented May 1, 2019

@stof what is the hold up for new release? Could we help you with this somehow?

@Kevin-Adrea

This comment has been minimized.

Copy link

@Kevin-Adrea Kevin-Adrea commented May 3, 2019

Tag pliz @stof !

@GDIBass

This comment has been minimized.

Copy link

@GDIBass GDIBass commented May 15, 2019

Another request for a new tag! Please, @stof ?

@apIncubout

This comment has been minimized.

Copy link

@apIncubout apIncubout commented May 15, 2019

Please @stof a new tag will be nice?

@miisieq

This comment has been minimized.

Copy link

@miisieq miisieq commented May 15, 2019

@stof, can we help you somehow to maintain this project?

@gsirin

This comment has been minimized.

Copy link

@gsirin gsirin commented May 22, 2019

@stof pleaaaaaaseeeeee...... tag it!

@javiereguiluz

This comment has been minimized.

Copy link
Contributor

@javiereguiluz javiereguiluz commented May 27, 2019

I know it's been a long wait, but please 🙏 try to understand that sometimes maintainers don't have time for their open source projects for some reasons.

I'm sure @stof will tag a new version when he's ready again to maintain this bundle. Please, have some patience. Moreover, not having a new version only means that you'll get some deprecation messages. It's not such a big deal. Thank you!

@JustBlackBird

This comment has been minimized.

Copy link

@JustBlackBird JustBlackBird commented May 27, 2019

@javiereguiluz can I somehow help to maintain the project?

@javiereguiluz

This comment has been minimized.

Copy link
Contributor

@javiereguiluz javiereguiluz commented May 28, 2019

@JustBlackBird I don't know, but thanks for trying to help! @stof is the maintainer of this bundle, so he will decide if he needs a helping hand.

@mmarton

This comment has been minimized.

Copy link

@mmarton mmarton commented Jun 5, 2019

I know it's been a long wait, but please pray try to understand that sometimes maintainers don't have time for their open source projects for some reasons.

I'm sure @stof will tag a new version when he's ready again to maintain this bundle. Please, have some patience. Moreover, not having a new version only means that you'll get some deprecation messages. It's not such a big deal. Thank you!

with all due respect, tagging a new release or at least answering to 3 month old issues in a widely used bundle isn't that hard

@tacman

This comment has been minimized.

Copy link

@tacman tacman commented Jun 10, 2019

The issue is that if developers get in the habit of ignoring messages (like the deprecation messages here) then it's easy to miss something that's more important. I think that 100% of my deprecation errors on a new Symfony 4.3 project are from this bundle, so was hoping to get rid of them (without changing stability and using dev-master). So just adding my voice to the chorus respectfully requesting a new version tag.

@nicodmf

This comment has been minimized.

Copy link

@nicodmf nicodmf commented Jun 12, 2019

@stof ?

@picks44

This comment has been minimized.

Copy link

@picks44 picks44 commented Jun 13, 2019

Same here, please find a way to fix this!

@apphancer

This comment has been minimized.

Copy link

@apphancer apphancer commented Jun 24, 2019

@stof please tag

@n-osennij

This comment has been minimized.

Copy link

@n-osennij n-osennij commented Jun 24, 2019

repo is dead...

@christophermichaelthomasmillar

This comment has been minimized.

Copy link

@christophermichaelthomasmillar christophermichaelthomasmillar commented Jul 10, 2019

It appears @stof is ignoring this repo. There are many forks of this repo already is there a supported one?

@geoff-maddock

This comment has been minimized.

Copy link

@geoff-maddock geoff-maddock commented Jul 29, 2019

Interested in this tag or maintained fork.

@mpdude

This comment has been minimized.

Copy link

@mpdude mpdude commented Aug 2, 2019

By the way, what’s the best pattern to handle this change while maintaining both Symfony <4.3 and ^4.3 compatibility?

@antishov

This comment has been minimized.

Copy link

@antishov antishov commented Aug 7, 2019

Hi, after waiting for a while, I made my own fork antishov/doctrine-extensions-bundle, tested master branch and released it as v1.4.0.
I really like this bundle and think that it's very helpful, so I plan to maintain it. Next steps are:

  • Fix issues from this repo
  • Remove support of old PHP versions: 5.3, 5.4, 5.5
  • Improve tests coverage
  • Prepare it for Symfony 4.4
  • Add support of PHP 7.3 and 7.4
@mmarton

This comment has been minimized.

Copy link

@mmarton mmarton commented Aug 7, 2019

@antishov respect for your decision. Let me know if you need any help.

@tacman

This comment has been minimized.

Copy link

@tacman tacman commented Aug 8, 2019

Remove support of old PHP versions: 5.3, 5.4, 5.5

IMO, there's no reason to support PHP5 at all. I would propose only supporting php7.1+.

How about dropping support altogether for Symfony 2 and 3? That is, only support Symfony 4.3 and 4.4. Anyone who needs this bundle for those versions can continue to use the original repo, and they won't switch to this fork

The master branch of the bundle is in sync with Symfony master branch which contains a BC break. If you are using a 2.0.x version of Symfony, you need to use the 1.0.x branch of the bundle.

This line in the documentation has always made me think that this bundle was a relic. Thank for for modernizing it!

@antishov

This comment has been minimized.

Copy link

@antishov antishov commented Aug 10, 2019

@tacman great ideas for a new major version, thank you!

@ghost

This comment has been minimized.

Copy link

@ghost ghost commented Sep 18, 2019

@gsirin

This comment has been minimized.

Copy link

@gsirin gsirin commented Sep 26, 2019

at least he is alive :)
symfony/demo#1029 (comment)

@JohJohan

This comment has been minimized.

Copy link

@JohJohan JohJohan commented Oct 7, 2019

+1

1 similar comment
@cobyl

This comment has been minimized.

Copy link

@cobyl cobyl commented Nov 1, 2019

+1

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
You can’t perform that action at this time.