Permalink
Browse files

Gem version 1.2.6. See changelog for details.

  • Loading branch information...
1 parent fa4b047 commit d00305fbb28164f0559716f00ecd43ffa696d159 @gmallard gmallard committed Sep 19, 2012
Showing with 15 additions and 7 deletions.
  1. +8 −0 CHANGELOG.rdoc
  2. +1 −0 README.rdoc
  3. +6 −7 stomp.gemspec
View
@@ -1,3 +1,11 @@
+== 1.2.6 20120913
+
+* Provide ability to eliminate checks for closed in protocol methods
+* Cover ssl.connect with connection timeout parameter
+* If heartbeat send raises, do not reraise unless client requests that
+* Remove methods that invoke __send__
+* Move internal methods to 'private'
+
== 1.2.5 20120804
* Issue #48 any forks with modifications will be affected!
View
@@ -10,6 +10,7 @@ An implementation of the Stomp protocol for Ruby. See:
===New
+* Gem version 1.2.6. Miscellaneous fixes and changes. See _CHANGELOG.rdoc_ for details.
* Gem version 1.2.5. Restructure. Forks with modifcations will be affected. See _CHANGELOG.rdoc_ for details.
* Gem version 1.2.4. Stomp 1.1 heartbeat fix, autoflush capability, miscellaneous fixes.
* Gem version 1.2.3. Miscellaneous fixes, see changelog for details.
View
@@ -4,13 +4,13 @@
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
- s.name = %q{stomp}
+ s.name = "stomp"
s.version = "1.2.6"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Brian McCallister", "Marius Mathiesen", "Thiago Morello", "Guy M. Allard"]
- s.date = %q{2012-09-12}
- s.description = %q{Ruby client for the Stomp messaging protocol. Note that this gem is no longer supported on rubyforge.}
+ s.date = "2012-09-13"
+ s.description = "Ruby client for the Stomp messaging protocol. Note that this gem is no longer supported on rubyforge."
s.email = ["brianm@apache.org", "marius@stones.com", "morellon@gmail.com", "allard.guy.m@gmail.com"]
s.executables = ["catstomp", "stompcat"]
s.extra_rdoc_files = [
@@ -130,13 +130,12 @@ Gem::Specification.new do |s|
"test/test_ssl.rb",
"test/tlogger.rb"
]
- s.homepage = %q{https://github.com/stompgem/stomp}
+ s.homepage = "https://github.com/stompgem/stomp"
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{Ruby client for the Stomp messaging protocol}
+ s.rubygems_version = "1.8.11"
+ s.summary = "Ruby client for the Stomp messaging protocol"
if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then

0 comments on commit d00305f

Please sign in to comment.