Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Updated to support Node 0.6.x

  • Loading branch information...
commit 5297d9ae09cac83fa2fabc0f739091e9b147acc3 1 parent aaaae04
Craig Walker authored
4 README.md
Source Rendered
@@ -19,11 +19,15 @@ node-extjs: the core library plus the models, controllers, stores, data access s
19 19 Installation
20 20 ------------
21 21
  22 +(Requires NodeJS 0.6.x)
  23 +
22 24 npm install node-extjs
23 25
24 26 Usage for core
25 27 --------------
26 28
  29 +(Requires NodeJS 0.6.x)
  30 +
27 31 require("node-extjs-core");
28 32
29 33 console.log(Ext.getVersion().version);
9 changelog.txt
... ... @@ -0,0 +1,9 @@
  1 +
  2 +December 2, 2011
  3 +
  4 +- Version bump to 1.0
  5 +- Upgraded to supported Node 0.6.x (no longer officially supports 0.4.x - but will most likely work)
  6 +
  7 +October 21, 2011
  8 +
  9 +- Upgraded ExtJS library to 4.07
14 examples/test/basic.js
... ... @@ -1,11 +1,15 @@
1   -require.paths.unshift(__dirname);
2   -require.paths.unshift(__dirname + "./../../../node-extjs");
3 1
4   -require("node-extjs");
  2 +require("./../../../node-extjs");
5 3
6   -console.log(Ext.getVersion().version);
  4 +console.log("version?", Ext.getVersion().version);
  5 +
  6 +Ext.Loader.setConfig({
  7 + enabled: true,
  8 + paths: {
  9 + ext: __dirname + "/ext"
  10 + }
  11 +});
7 12
8   -Ext.ns("ext");
9 13 Ext.require("ext.test");
10 14
11 15 console.log(new ext.test());
9 examples/test/server.js
... ... @@ -1,8 +1,5 @@
1 1
2   -require.paths.unshift(__dirname);
3   -require.paths.unshift(__dirname + "./../../../node-extjs");
4   -
5   -require("node-extjs");
  2 +require("./../../../node-extjs");
6 3
7 4 Ext.Loader.setConfig({
8 5 enabled: true,
@@ -29,6 +26,8 @@ console.log(user.getAssociatedData());
29 26
30 27 var errors = user.validate();
31 28
32   -console.log(typeof errors);
  29 +errors.each(function(err) {
  30 + console.log(err);
  31 +});
33 32
34 33
5 node-extjs-core.js
... ... @@ -1,8 +1,5 @@
1 1
2   -require.paths.unshift(__dirname);
3   -require.paths.unshift(__dirname + "/lib");
4   -
5   -var utils = require("utils");
  2 +var utils = require("./lib/utils");
6 3
7 4 var fileList = [
8 5 "/extjs/src/core/src/Ext.js",
6 node-extjs.js
... ... @@ -1,9 +1,7 @@
1 1
2   -require.paths.unshift(__dirname);
  2 +require("./node-extjs-core");
3 3
4   -require("node-extjs-core");
5   -
6   -var utils = require("utils");
  4 +var utils = require("./lib/utils");
7 5
8 6 var fileList = [
9 7 "/extjs/src/data/Connection.js",
4 package.json
@@ -4,12 +4,12 @@
4 4 "main": "node-extjs",
5 5 "homepage": "https://github.com/storminwalker/node-extjs",
6 6 "description": "ExtJS module for Node",
7   - "version": "0.1.2",
  7 + "version": "1.0.0",
8 8 "repository": {
9 9 "type": "git",
10 10 "url": "https://github.com/storminwalker/node-extjs"
11 11 },
12 12 "engines": {
13   - "node": ">=0.4.0"
  13 + "node": ">=0.6.0"
14 14 }
15 15 }

0 comments on commit 5297d9a

Please sign in to comment.
Something went wrong with that request. Please try again.