Permalink
Browse files

Added article support

  • Loading branch information...
1 parent 9e526bf commit 8d78fe3ab44f1e6a108110898c2a87262e07db87 @idyll idyll committed May 1, 2012
View
3 .rvmrc
@@ -1,2 +1 @@
-rvm use ruby-1.9.2-p290
-
+rvm use ruby-1.9.3-p194
View
20 Gemfile
@@ -1,6 +1,6 @@
source 'http://rubygems.org'
-gem 'rails', '3.1.0.rc6'
+gem 'rails', '3.1.4'
# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'
@@ -9,11 +9,11 @@ gem 'json'
# Gems used only for assets and not required
# in production environments by default.
-#group :assets do
+group :assets do
# gem 'sass-rails', " ~> 3.1.0.rc"
# gem 'coffee-rails', "~> 3.1.0.rc"
# gem 'uglifier'
-#end
+end
gem 'jquery-rails'
@@ -25,15 +25,13 @@ gem 'cloudfiles'
gem 'cocaine' #a dependency that paperclilp didn't pick up yet
gem "paperclip-cloudfiles", :require => 'paperclip'
#gem 'paperclip'
-gem 'devise'
+gem 'devise', "~> 2.0.2"
gem 'cancan', '1.6.0'
gem 'bcrypt-ruby'
gem 'RedCloth'
gem 'acts_as_list'
gem 'kaminari'
-gem 'thinking-sphinx',
- :git => 'git://github.com/freelancing-god/thinking-sphinx.git',
- :branch => 'rails3'
+gem 'thinking-sphinx'
# Use unicorn as the web server
# gem 'unicorn'
@@ -52,16 +50,18 @@ gem 'thinking-sphinx',
# gem 'aws-s3', :require => 'aws/s3'
# Bundle gems for the local environment. Make sure to
+group :test do
+ gem 'cucumber-rails'
+ gem 'cucumber'
+end
group :test, :development do
gem 'factory_girl_rails'
gem 'capybara'
gem 'rack-test'
gem 'database_cleaner'
- gem 'cucumber-rails'
- gem 'cucumber'
gem 'rspec-rails'
- gem "shoulda"
+ gem "shoulda", :require => false
gem 'spork'
gem 'launchy' # So you can do Then show me the page
end
View
@@ -1,178 +1,183 @@
-GIT
- remote: git://github.com/freelancing-god/thinking-sphinx.git
- revision: f44dd2dff3aed646b11fd12ce09d243ccd42c931
- branch: rails3
- specs:
- thinking-sphinx (2.0.5)
- activerecord (>= 3.0.3)
- riddle (>= 1.3.3)
-
GEM
remote: http://rubygems.org/
specs:
- RedCloth (4.2.8)
- actionmailer (3.1.0.rc6)
- actionpack (= 3.1.0.rc6)
+ RedCloth (4.2.9)
+ actionmailer (3.1.4)
+ actionpack (= 3.1.4)
mail (~> 2.3.0)
- actionpack (3.1.0.rc6)
- activemodel (= 3.1.0.rc6)
- activesupport (= 3.1.0.rc6)
+ actionpack (3.1.4)
+ activemodel (= 3.1.4)
+ activesupport (= 3.1.4)
builder (~> 3.0.0)
erubis (~> 2.7.0)
i18n (~> 0.6)
- rack (~> 1.3.2)
- rack-cache (~> 1.0.2)
- rack-mount (~> 0.8.1)
- rack-test (~> 0.6.0)
- sprockets (~> 2.0.0.beta.12)
- activemodel (3.1.0.rc6)
- activesupport (= 3.1.0.rc6)
- bcrypt-ruby (~> 2.1.4)
+ rack (~> 1.3.6)
+ rack-cache (~> 1.1)
+ rack-mount (~> 0.8.2)
+ rack-test (~> 0.6.1)
+ sprockets (~> 2.0.3)
+ activemodel (3.1.4)
+ activesupport (= 3.1.4)
builder (~> 3.0.0)
i18n (~> 0.6)
- activerecord (3.1.0.rc6)
- activemodel (= 3.1.0.rc6)
- activesupport (= 3.1.0.rc6)
- arel (~> 2.2.1)
+ activerecord (3.1.4)
+ activemodel (= 3.1.4)
+ activesupport (= 3.1.4)
+ arel (~> 2.2.3)
tzinfo (~> 0.3.29)
- activeresource (3.1.0.rc6)
- activemodel (= 3.1.0.rc6)
- activesupport (= 3.1.0.rc6)
- activesupport (3.1.0.rc6)
+ activeresource (3.1.4)
+ activemodel (= 3.1.4)
+ activesupport (= 3.1.4)
+ activesupport (3.1.4)
multi_json (~> 1.0)
- acts_as_list (0.1.4)
- addressable (2.2.6)
- arel (2.2.1)
- bcrypt-ruby (2.1.4)
+ acts_as_list (0.1.6)
+ addressable (2.2.7)
+ arel (2.2.3)
+ bcrypt-ruby (3.0.1)
builder (3.0.0)
cancan (1.6.0)
- capybara (1.0.1)
+ capybara (1.1.2)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
selenium-webdriver (~> 2.0)
xpath (~> 0.1.4)
- childprocess (0.2.1)
+ childprocess (0.3.2)
ffi (~> 1.0.6)
- ckeditor (3.6.1)
+ ckeditor (3.6.3)
mime-types (~> 1.16)
orm_adapter (~> 0.0.5)
- cloudfiles (1.4.17)
- mime-types (>= 1.16)
- cocaine (0.2.0)
- cucumber (1.0.2)
+ cloudfiles (1.5.0.1)
+ json
+ cocaine (0.2.1)
+ cucumber (1.1.9)
builder (>= 2.1.2)
diff-lcs (>= 1.1.2)
- gherkin (~> 2.4.5)
+ gherkin (~> 2.9.0)
json (>= 1.4.6)
- term-ansicolor (>= 1.0.5)
- cucumber-rails (1.0.2)
- capybara (>= 1.0.0)
- cucumber (~> 1.0.0)
- nokogiri (>= 1.4.6)
- database_cleaner (0.6.7)
- devise (1.4.2)
- bcrypt-ruby (~> 2.1.2)
+ term-ansicolor (>= 1.0.6)
+ cucumber-rails (1.3.0)
+ capybara (>= 1.1.2)
+ cucumber (>= 1.1.8)
+ nokogiri (>= 1.5.0)
+ database_cleaner (0.7.2)
+ devise (2.0.4)
+ bcrypt-ruby (~> 3.0)
orm_adapter (~> 0.0.3)
- warden (~> 1.0.3)
- diff-lcs (1.1.2)
+ railties (~> 3.1)
+ warden (~> 1.1.1)
+ diff-lcs (1.1.3)
erubis (2.7.0)
- factory_girl (2.0.5)
- factory_girl_rails (1.1.0)
- factory_girl (~> 2.0.0)
+ factory_girl (3.2.0)
+ activesupport (>= 3.0.0)
+ factory_girl_rails (3.2.0)
+ factory_girl (~> 3.2.0)
railties (>= 3.0.0)
- ffi (1.0.9)
- gherkin (2.4.15)
+ ffi (1.0.11)
+ gherkin (2.9.3)
json (>= 1.4.6)
- high_voltage (1.0.0)
+ high_voltage (1.1.1)
hike (1.2.1)
i18n (0.6.0)
- jquery-rails (1.0.13)
+ jquery-rails (1.0.19)
railties (~> 3.0)
thor (~> 0.14)
- json (1.5.3)
- json_pure (1.5.3)
- kaminari (0.12.4)
- rails (>= 3.0.0)
- launchy (2.0.5)
+ json (1.7.0)
+ kaminari (0.13.0)
+ actionpack (>= 3.0.0)
+ activesupport (>= 3.0.0)
+ railties (>= 3.0.0)
+ launchy (2.1.0)
addressable (~> 2.2.6)
- mail (2.3.0)
+ libwebsocket (0.1.3)
+ addressable
+ mail (2.3.3)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- mime-types (1.16)
- multi_json (1.0.3)
- mysql2 (0.3.7)
- nokogiri (1.5.0)
- orm_adapter (0.0.5)
+ mime-types (1.18)
+ multi_json (1.3.4)
+ mysql2 (0.3.11)
+ nokogiri (1.5.2)
+ orm_adapter (0.0.7)
paperclip-cloudfiles (2.3.10.1)
activerecord
activesupport
- polyglot (0.3.2)
- rack (1.3.2)
- rack-cache (1.0.2)
+ polyglot (0.3.3)
+ rack (1.3.6)
+ rack-cache (1.2)
rack (>= 0.4)
- rack-mount (0.8.2)
+ rack-mount (0.8.3)
rack (>= 1.0.0)
rack-ssl (1.3.2)
rack
rack-test (0.6.1)
rack (>= 1.0)
- rails (3.1.0.rc6)
- actionmailer (= 3.1.0.rc6)
- actionpack (= 3.1.0.rc6)
- activerecord (= 3.1.0.rc6)
- activeresource (= 3.1.0.rc6)
- activesupport (= 3.1.0.rc6)
+ rails (3.1.4)
+ actionmailer (= 3.1.4)
+ actionpack (= 3.1.4)
+ activerecord (= 3.1.4)
+ activeresource (= 3.1.4)
+ activesupport (= 3.1.4)
bundler (~> 1.0)
- railties (= 3.1.0.rc6)
- railties (3.1.0.rc6)
- actionpack (= 3.1.0.rc6)
- activesupport (= 3.1.0.rc6)
+ railties (= 3.1.4)
+ railties (3.1.4)
+ actionpack (= 3.1.4)
+ activesupport (= 3.1.4)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (~> 0.14.6)
- rake (0.9.2)
- rdoc (3.9.3)
- riddle (1.4.0)
- rspec (2.6.0)
- rspec-core (~> 2.6.0)
- rspec-expectations (~> 2.6.0)
- rspec-mocks (~> 2.6.0)
- rspec-core (2.6.4)
- rspec-expectations (2.6.0)
- diff-lcs (~> 1.1.2)
- rspec-mocks (2.6.0)
- rspec-rails (2.6.1)
- actionpack (~> 3.0)
- activesupport (~> 3.0)
- railties (~> 3.0)
- rspec (~> 2.6.0)
- rubyzip (0.9.4)
- selenium-webdriver (2.5.0)
- childprocess (>= 0.2.1)
- ffi (>= 1.0.7)
- json_pure
+ rake (0.9.2.2)
+ rdoc (3.12)
+ json (~> 1.4)
+ riddle (1.5.1)
+ rspec (2.9.0)
+ rspec-core (~> 2.9.0)
+ rspec-expectations (~> 2.9.0)
+ rspec-mocks (~> 2.9.0)
+ rspec-core (2.9.0)
+ rspec-expectations (2.9.1)
+ diff-lcs (~> 1.1.3)
+ rspec-mocks (2.9.0)
+ rspec-rails (2.9.0)
+ actionpack (>= 3.0)
+ activesupport (>= 3.0)
+ railties (>= 3.0)
+ rspec (~> 2.9.0)
+ rubyzip (0.9.8)
+ selenium-webdriver (2.21.2)
+ childprocess (>= 0.2.5)
+ ffi (~> 1.0)
+ libwebsocket (~> 0.1.3)
+ multi_json (~> 1.0)
rubyzip
- shoulda (2.11.3)
- simple_form (1.4.2)
+ shoulda (3.0.1)
+ shoulda-context (~> 1.0.0)
+ shoulda-matchers (~> 1.0.0)
+ shoulda-context (1.0.0)
+ shoulda-matchers (1.0.0)
+ simple_form (2.0.2)
actionpack (~> 3.0)
activemodel (~> 3.0)
- spork (0.8.5)
- sprockets (2.0.0.beta.15)
+ spork (0.9.0)
+ sprockets (2.0.4)
hike (~> 1.2)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
- term-ansicolor (1.0.6)
+ term-ansicolor (1.0.7)
+ thinking-sphinx (2.0.11)
+ activerecord (>= 3.0.3)
+ builder (>= 2.1.2)
+ riddle (>= 1.5.0)
thor (0.14.6)
tilt (1.3.3)
treetop (1.4.10)
polyglot
polyglot (>= 0.3.1)
- tzinfo (0.3.29)
- warden (1.0.5)
+ tzinfo (0.3.33)
+ warden (1.1.1)
rack (>= 1.0)
xpath (0.1.4)
nokogiri (~> 1.3)
@@ -192,7 +197,7 @@ DEPENDENCIES
cucumber
cucumber-rails
database_cleaner
- devise
+ devise (~> 2.0.2)
factory_girl_rails
high_voltage
jquery-rails
@@ -202,9 +207,9 @@ DEPENDENCIES
mysql2
paperclip-cloudfiles
rack-test
- rails (= 3.1.0.rc6)
+ rails (= 3.1.4)
rspec-rails
shoulda
simple_form
spork
- thinking-sphinx!
+ thinking-sphinx
Oops, something went wrong.

0 comments on commit 8d78fe3

Please sign in to comment.