Skip to content
This repository

Stripe Java bindings

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 src
Octocat-spinner-32 .gitignore
Octocat-spinner-32 .travis.yml Enable travis-ci May 04, 2012
Octocat-spinner-32 CHANGELOG
Octocat-spinner-32 LICENSE license header August 09, 2011
Octocat-spinner-32 README.md
Octocat-spinner-32 VERSION
Octocat-spinner-32 pom.xml
README.md

Stripe Java Bindings

You can sign up for a Stripe account at https://stripe.com.

Requirements

Java 1.5 and later.

Installation

Maven users

Add this dependency to your project's POM:

<dependency>
  <groupId>com.stripe</groupId>
  <artifactId>stripe-java</artifactId>
  <version>1.1.16</version>
</dependency>

Others

You'll need to manually install the following JARs:

Usage

StripeExample.java

import java.util.HashMap;
import java.util.Map;

import com.stripe.Stripe;
import com.stripe.exception.StripeException;
import com.stripe.model.Charge;

public class StripeExample {

    public static void main(String[] args) {
        Stripe.apiKey = "YOUR-SECRET-KEY";
        Map<String, Object> chargeMap = new HashMap<String, Object>();
        chargeMap.put("amount", 100);
        chargeMap.put("currency", "usd");
        Map<String, Object> cardMap = new HashMap<String, Object>();
        cardMap.put("number", "4242424242424242");
        cardMap.put("exp_month", 12);
        cardMap.put("exp_year", 2012);
        chargeMap.put("card", cardMap);
        try {
            Charge charge = Charge.create(chargeMap);
            System.out.println(charge);
        } catch (StripeException e) {
            e.printStackTrace();
        }
    }
}

See StripeTest.java for more examples.

Something went wrong with that request. Please try again.