Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Stripe Python bindings

This branch is 0 commits ahead and 141 commits behind master

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 bin
Octocat-spinner-32 stripe
Octocat-spinner-32 test
Octocat-spinner-32 .gitignore Update .gitignore June 01, 2012
Octocat-spinner-32 .travis.yml
Octocat-spinner-32 CHANGELOG
Octocat-spinner-32 CONTRIBUTORS Add CONTRIBUTORS doc May 28, 2011
Octocat-spinner-32 LICENSE 1.5.0 release May 26, 2011
Octocat-spinner-32 MANIFEST.in Add MANIFEST.in for cross-version build compatibility October 29, 2011
Octocat-spinner-32 README.rdoc Drop the "sudo" from pip and easy_install instructions October 16, 2012
Octocat-spinner-32 VERSION
Octocat-spinner-32 example.py Use a new API key just for testing bindings in test suite May 03, 2012
Octocat-spinner-32 setup.py
Octocat-spinner-32 tox.ini
README.rdoc

Stripe Python bindings

Installation

You don't need this source code unless you want to modify the package. If you just want to use the Stripe Python bindings, you should run:

pip install --index-url https://code.stripe.com --upgrade stripe

or

easy_install --index-url https://code.stripe.com --upgrade stripe

See www.pip-installer.org/en/latest/index.html for instructions on installing pip. If you are on a system with easy_install but not pip, you can use easy_install instead. If you're not using virtualenv, you may have to prefix those commands with sudo. You can learn more about virtualenv at www.virtualenv.org/

To install from source, run:

python setup.py install

Documentation

Please see stripe.com/api for the most up-to-date documentation.

Something went wrong with that request. Please try again.