Permalink
Browse files

Update deps and roll version 0.4.0.

  • Loading branch information...
1 parent 4f12c6c commit d622482941f814bf1465538df6a5d21c1fae6790 @seancribbs seancribbs committed Feb 6, 2012
Showing with 23 additions and 40 deletions.
  1. +3 −1 .travis.yml
  2. +12 −10 Gemfile
  3. +1 −1 Guardfile
  4. +1 −1 lib/webmachine/version.rb
  5. +6 −27 webmachine.gemspec
View
@@ -2,5 +2,7 @@ rvm:
- 1.8.7
- 1.9.2
- 1.9.3
- - rbx
+ - rbx-18mode
+ - rbx-19mode
- jruby
+bundler_args: --without=guard,docs
View
22 Gemfile
@@ -6,20 +6,22 @@ gemspec
gem 'bundler'
-unless ENV['TRAVIS']
+group :guard do
gem 'guard-rspec'
+ case RbConfig::CONFIG['host_os']
+ when /darwin/
+ gem 'rb-fsevent'
+ # gem 'growl_notify'
+ gem 'growl'
+ when /linux/
+ gem 'rb-inotify'
+ gem 'libnotify'
+ end
+end
+group :docs do
platform :mri do
gem 'redcarpet'
-
- case RbConfig::CONFIG['host_os']
- when /darwin/
- gem 'rb-fsevent'
- gem 'growl_notify'
- when /linux/
- gem 'rb-inotify'
- gem 'libnotify'
- end
end
end
View
@@ -1,7 +1,7 @@
gemset = ENV['RVM_GEMSET'] || 'webmachine'
gemset = "@#{gemset}" unless gemset.to_s == ''
-rvms = %W[ 1.8.7 1.9.2 jruby rbx ].map {|v| "#{v}#{gemset}" }
+rvms = %W[ 1.8.7 1.9.2 1.9.3 jruby rbx ].map {|v| "#{v}#{gemset}" }
guard 'rspec', :cli => "--color --profile", :growl => true, :rvm => rvms do
watch(%r{^lib/webmachine/locale/.+$}) { "spec" }
@@ -1,6 +1,6 @@
module Webmachine
# Library version
- VERSION = "0.3.0"
+ VERSION = "0.4.0"
# String for use in "Server" HTTP response header, which includes
# the {VERSION}.
View
@@ -4,7 +4,6 @@ require 'webmachine/version'
Gem::Specification.new do |gem|
gem.name = "webmachine"
gem.version = Webmachine::VERSION
- gem.date = File.mtime("lib/webmachine/version.rb")
gem.summary = %Q{webmachine is a toolkit for building HTTP applications,}
gem.description = <<-DESC.gsub(/\s+/, ' ')
webmachine is a toolkit for building HTTP applications in a declarative fashion, that avoids
@@ -15,32 +14,12 @@ Gem::Specification.new do |gem|
gem.authors = ["Sean Cribbs"]
gem.email = ["sean@basho.com"]
- if gem.respond_to? :specification_version then
- gem.specification_version = 3
-
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- gem.add_runtime_dependency(%q<i18n>, [">= 0.4.0"])
- gem.add_development_dependency(%q<rspec>, ["~> 2.6.0"])
- gem.add_development_dependency(%q<yard>, ["~> 0.7.3"])
- gem.add_development_dependency(%q<rake>)
- gem.add_development_dependency(%q<mongrel>, ['~>1.2.beta'])
- gem.add_development_dependency(%q<rack>)
- else
- gem.add_dependency(%q<i18n>, [">= 0.4.0"])
- gem.add_dependency(%q<rspec>, ["~> 2.6.0"])
- gem.add_dependency(%q<yard>, ["~> 0.7.3"])
- gem.add_dependency(%q<rake>)
- gem.add_dependency(%q<mongrel>, ['~>1.2.beta'])
- gem.add_dependency(%q<rack>)
- end
- else
- gem.add_dependency(%q<i18n>, [">= 0.4.0"])
- gem.add_dependency(%q<rspec>, ["~> 2.6.0"])
- gem.add_dependency(%q<yard>, ["~> 0.7.3"])
- gem.add_dependency(%q<rake>)
- gem.add_dependency(%q<mongrel>, ['~>1.2.beta'])
- gem.add_dependency(%q<rack>)
- end
+ gem.add_runtime_dependency(%q<i18n>, [">= 0.4.0"])
+ gem.add_development_dependency(%q<rspec>, ["~> 2.8.0"])
+ gem.add_development_dependency(%q<yard>, ["~> 0.7.3"])
+ gem.add_development_dependency(%q<rake>)
+ gem.add_development_dependency(%q<mongrel>, ['~>1.2.beta'])
+ gem.add_development_dependency(%q<rack>)
ignores = File.read(".gitignore").split(/\r?\n/).reject{ |f| f =~ /^(#.+|\s*)$/ }.map {|f| Dir[f] }.flatten
gem.files = (Dir['**/*','.gitignore'] - ignores).reject {|f| !File.file?(f) }

0 comments on commit d622482

Please sign in to comment.