Skip to content


Subversion checkout URL

You can clone with
Download ZIP


Unable to install on node v0.5.5-pre #819

ghost opened this Issue · 2 comments

2 participants


Express is not compatible with v0.5.5-pre.

node v0.5.5-pre
npm v1.0.26

npm ERR! Unsupported
npm ERR! Not compatible with your version of node/npm: express@2.4.4
npm ERR! Required: {"node":">= 0.4.1 < 0.5.0"}
npm ERR! Actual: {"npm":"1.0.26","node":"v0.5.5-pre"}
npm ERR!
npm ERR! System Darwin 11.1.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "express"
npm ERR! cwd /Users/roosteronacid/Library/node/npm
npm ERR! node -v v0.5.5-pre
npm ERR! npm -v 1.0.26
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /Users/roosteronacid/Library/node/npm/npm-debug.log
npm not ok

@tj tj closed this

So what's the workaround? or is it just not supported?

tj commented

0.5.x is unstable, if you want to force code to run on it that have not tested 0.5.x you'll have to git clone instead of npm

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.