Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 75 lines (74 sloc) 2.345 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74
<?xml version="1.0" encoding="UTF-8"?>
<package xmlns="http://pear.php.net/dtd/package-2.0" xmlns:tasks="http://pear.php.net/dtd/tasks-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" packagerversion="1.9.1" version="2.0" xsi:schemaLocation="http://pear.php.net/dtd/tasks-1.0 http://pear.php.net/dtd/tasks-1.0.xsd http://pear.php.net/dtd/package-2.0 http://pear.php.net/dtd/package-2.0.xsd">
  <name>${project.name}</name>
  <channel>${project.channel}</channel>
  <summary>An easy-to-use PHP library for helping with Programming By Contract in PHP</summary>
  <description>
    ContractLib is a lightweight PHP library designed to help you write more robust PHP components by helping your components enforce programming contracts throughout your code.
  </description>
  <lead>
    <name>Stuart Herbert</name>
    <user>stuartherbert</user>
    <email>stuart@stuartherbert.com</email>
    <active>yes</active>
  </lead>
  <date>${build.date}</date>
  <time>${build.time}</time>
  <version>
    <release>${project.version}</release>
    <api>${project.majorVersion}.${project.minorVersion}</api>
  </version>
  <stability>
    <release>${project.stability}</release>
    <api>stable</api>
  </stability>
  <license>New BSD license</license>
  <notes>
    No notes.
  </notes>
  <contents>
    <dir baseinstalldir="/" name="/">
${contents}
    </dir>
  </contents>
  <dependencies>
    <required>
      <php>
        <min>5.3.0</min>
      </php>
      <pearinstaller>
        <min>1.9.4</min>
      </pearinstaller>
      <package>
        <name>Autoloader4</name>
        <channel>pear.phix-project.org</channel>
        <min>4.0.0</min>
        <max>4.999.9999</max>
      </package>
      <package>
        <name>ExceptionsLib1</name>
        <channel>pear.phix-project.org</channel>
        <min>1.0.0</min>
        <max>1.999.9999</max>
      </package>
    </required>
  </dependencies>
  <phprelease/>
  <changelog>
    <release>
      <version>
        <release>1.0.0</release>
        <api>1.0</api>
      </version>
      <stability>
        <release>stable</release>
        <api>stable</api>
      </stability>
      <date>Your release date</date>
      <license>New BSD license</license>
      <notes>
      </notes>
    </release>
  </changelog>
</package>
<!-- vim: set tabstop=2 shiftwidth=2 expandtab: -->
Something went wrong with that request. Please try again.