Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bump prettier from 2.6.1 to 2.6.2 #147

Merged
merged 1 commit into from Apr 4, 2022

Conversation

dependabot[bot]
Copy link
Contributor

@dependabot dependabot bot commented on behalf of github Apr 4, 2022

Bumps prettier from 2.6.1 to 2.6.2.

Release notes

Sourced from prettier's releases.

2.6.2

🔗 Changelog

Changelog

Sourced from prettier's changelog.

2.6.2

diff

Fix LESS/SCSS format error (#12536 by @​fisker)

// Input
.background-gradient(@cut) {
    background: linear-gradient(
        to right,
        @white 0%,
        @white (@cut - 0.01%),
        @portal-background @cut,
        @portal-background 100%
    );
}
// Prettier 2.6.1
TypeError: Cannot read properties of undefined (reading 'endOffset')
// Prettier 2.6.2
.background-gradient(@​cut) {
background: linear-gradient(
to right,
@​white 0%,
@​white (@​cut - 0.01%),
@​portal-background @​cut,
@​portal-background 100%
);
}

Update meriyah to fix several bugs (#12567 by @​fisker, fixes in meriyah by @​3cp)

Fixes bugs when parsing following valid code:

foo(await bar());
const regex = /.*/ms;
const element = <p>{/w/.test(s)}</p>;

... (truncated)

Commits
  • d6f82a0 Release 2.6.2
  • 2bca9d6 Add new workflow to prevent updating users.yml (#11784)
  • 378370a Build(deps): Bump leven from 3.1.0 to 4.0.0 (#11349)
  • 3c96a08 Build(deps): Bump strip-ansi from 6.0.0 to 7.0.0 (#10731)
  • 1bfb08f Build(deps): Bump meriyah from 4.2.0 to 4.2.1 (#12567)
  • 9400c89 Refactor: Add a wrapped normalizeCliOptions version for CLI usage (#12573)
  • 5e3de48 Build(deps): Bump escape-string-regexp from 4.0.0 to 5.0.0 (#10725)
  • 5d73acc Build(deps-dev): Bump esbuild from 0.14.29 to 0.14.30 (#12581)
  • e2eac0c Move some bundle test code into tests/ (#12577)
  • 7d33ed5 Build(deps-dev): Bump eslint-plugin-unicorn from 41.0.1 to 42.0.0 (#12580)
  • Additional commits viewable in compare view

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


Dependabot commands and options

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

Bumps [prettier](https://github.com/prettier/prettier) from 2.6.1 to 2.6.2.
- [Release notes](https://github.com/prettier/prettier/releases)
- [Changelog](https://github.com/prettier/prettier/blob/main/CHANGELOG.md)
- [Commits](prettier/prettier@2.6.1...2.6.2)

---
updated-dependencies:
- dependency-name: prettier
  dependency-type: direct:development
  update-type: version-update:semver-patch
...

Signed-off-by: dependabot[bot] <support@github.com>
@dependabot dependabot bot added dependencies Pull requests that update a dependency file javascript Pull requests that update Javascript code labels Apr 4, 2022
@styfle styfle merged commit 00de276 into main Apr 4, 2022
7 checks passed
@styfle styfle deleted the dependabot/npm_and_yarn/prettier-2.6.2 branch Apr 4, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
dependencies Pull requests that update a dependency file javascript Pull requests that update Javascript code
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

1 participant