I know I can upgrade.
But I recommend at least updating minor version.
Because now for example browserify requires 0.8 too.
"http-browserify" : "~0.1.1",
I've kinda (temporarily) solved it with shrinkwrap
npm help shrinkwrap
At the very least, it would have been nice to change minor version, since browserify depends on ~0.1.1, and this is frankly a breaking change, so I'd like to be able to choose when I upgrade.
Try upgrading npm to the latest version where the engine field is advisory or you can try npm install -f browserify so that npm will install it anyways.
npm install -f browserify
OK. But still this does not solve the issue: same version of browserify can not be installed anymore from our build script without changing it.
If nothing else, update package.json engine field to 0.8.
I just ran into this. Quite confusing when i saw that Browserify required 0.6, but was failing for anything under 0.8.
I'm still using node 0.6 with browserify with npm 1.1.41 where the engines field is advisory but still works on node 0.6:
npm -g install email@example.com