Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

/home/substack referenced somewhere #9

Closed
isaacs opened this Issue · 2 comments

1 participant

@isaacs

Seeing this when I try to install:

[node@b274384b-e59b-4733-ac19-3a7e0c8a0f52 ~]$ npm install bigint

> bigint@0.3.2 install /home/node/node_modules/bigint
> node-waf configure build

Checking for program g++ or c++          : /home/node/local/bin/g++ 
Checking for program cpp                 : /home/node/local/bin/cpp 
Checking for program ar                  : /opt/local/bin/ar 
Checking for program ranlib              : /opt/local/bin/ranlib 
Checking for g++                         : ok  
Checking for node path                   : not found 
Checking for node prefix                 : ok /opt/nodejs/v0.4.5 
'configure' finished successfully (0.081s)
Waf: Entering directory `/home/substack/projects/node-bigint/build'
Waf: Leaving directory `/home/substack/projects/node-bigint/build'
Traceback (most recent call last):
  File "/home/node/local/nodejs/bin/node-waf", line 16, in <module>
    Scripting.prepare(t, os.getcwd(), VERSION, wafdir)
  File "/opt/nodejs/v0.4.5/bin/../lib/node/wafadmin/Scripting.py", line 145, in prepare
    prepare_impl(t, cwd, ver, wafdir)
  File "/opt/nodejs/v0.4.5/bin/../lib/node/wafadmin/Scripting.py", line 135, in prepare_impl
    main()
  File "/opt/nodejs/v0.4.5/bin/../lib/node/wafadmin/Scripting.py", line 188, in main
    fun(ctx)
  File "/opt/nodejs/v0.4.5/bin/../lib/node/wafadmin/Scripting.py", line 386, in build
    return build_impl(bld)
  File "/opt/nodejs/v0.4.5/bin/../lib/node/wafadmin/Scripting.py", line 405, in build_impl
    bld.compile()
  File "/opt/nodejs/v0.4.5/bin/../lib/node/wafadmin/Build.py", line 268, in compile
    os.chdir(self.bldnode.abspath())
OSError: [Errno 2] No such file or directory: '/home/substack/projects/node-bigint/build'
npm ERR! error installing bigint@0.3.2 Error: bigint@0.3.2 install: `node-waf configure build`
npm ERR! error installing bigint@0.3.2 `sh "-c" "node-waf configure build"` failed with 1
npm ERR! error installing bigint@0.3.2     at ChildProcess.<anonymous> (/opt/nodejs/lib/node_modules/npm/lib/utils/exec.js:49:20)
npm ERR! error installing bigint@0.3.2     at ChildProcess.emit (events.js:67:17)
npm ERR! error installing bigint@0.3.2     at ChildProcess.onexit (child_process.js:192:12)
npm ERR! bigint@0.3.2 install: `node-waf configure build`
npm ERR! `sh "-c" "node-waf configure build"` failed with 1
npm ERR! 
npm ERR! Failed at the bigint@0.3.2 install script.
npm ERR! This is most likely a problem with the bigint package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-waf configure build
npm ERR! You can get their info via:
npm ERR!     npm owner ls bigint
npm ERR! There is likely additional logging output above.
npm ERR! 
npm ERR! System SunOS 5.11
npm ERR! command "/opt/nodejs/v0.4/bin/node" "/opt/nodejs/bin/npm" "install" "bigint"
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/node/npm-debug.log
npm not ok
@isaacs

Hm.. on further investigation, this looks like an npm issue. You've got "build" in your npmignore file, so it shouldn't be including that in the tarball, and yet it is. That's a problem.

@isaacs

Fixed on npm/npm@5f1c33b. Releasing a new rc today, please update before publishing again :)

@isaacs isaacs closed this
@indexzero indexzero referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.