Skip to content

1.9 specific code fails under JRuby 1.6.8 #8

Closed
postmodern opened this Issue Oct 15, 2012 · 4 comments

2 participants

@postmodern

While testing md2man master with JRuby 1.6.8, I got this error:

undefined method `each_key' for []:Array
/home/hal/.gem/jruby/1.8.7/bundler/gems/md2man-7746a87c2c9c/lib/md2man/document.rb:117:in `decode_references'
/home/hal/.gem/jruby/1.8.7/bundler/gems/md2man-7746a87c2c9c/lib/md2man/document.rb:90:in `codespan'
/home/hal/.gem/jruby/1.8.7/bundler/gems/md2man-7746a87c2c9c/lib/md2man/roff.rb:165:in `codespan'
/home/hal/.gem/jruby/1.8.7/bundler/gems/md2man-7746a87c2c9c/lib/md2man/tasks.rb:55:in `define'
/home/hal/.gem/jruby/1.8.7/bundler/gems/md2man-7746a87c2c9c/lib/md2man/tasks.rb:128:in `render'

However, md2man works fine under MRI 1.9.3.

@sunaku
Owner
sunaku commented Oct 16, 2012

I just observed that Redcarpet 2.2.1 doesn't build under Ruby 1.8.7, in addition to JRuby as #9 reports.

I've become weary of Ruby 1.8's syntax and stdlib limitations, so I'm tempted to stop supporting it. 😫

@postmodern

1.8.7 is dying, so it might be time to add required_ruby_version = '>= 1.9.1' to the gemspec.

@sunaku
Owner
sunaku commented Oct 17, 2012

Ah, so that's how it's done! Thanks for the tip.

@sunaku
Owner
sunaku commented Feb 23, 2013

Fixed in 66a0dab.

@sunaku sunaku closed this Feb 23, 2013
@sunaku sunaku pushed a commit that referenced this issue Feb 23, 2013
Suraj N. Kurapati GH-8: Redcarpet requires Ruby 1.9 and so must we
#8 (comment)

Thanks to Postmodern for raising this issue.
92283e8
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.